Treadmill Controller - No power to motor

Thread Starter


Joined Feb 10, 2012
Hi all,

I'm enthusiastic, but by no means 'competent' in the context of detailed troubleshooting of circuits. I've mucked around with low voltage hobby stuff in the past, but not mains-driven high-voltage components... Hopefully someone can find the patience to guide me :)

I've attached a few pics of the controller board for context..

found here...

Long story short - (In Australia) we bought a used Healthstream Evo 3225 tradmill from Ebay, which worked fine for a couple of weeks, and one day (while I wasn't home) whilst the treadmill motor was attempting to 'start' running there was a loud 'pop' which end up tripping at the house main

fuse board.

Something obviously blew :)

When I got home I checked the obvious stuff (general connections/fuses etc), and the ceramic fuse on the controller board had blown (which I hoped was a good sign). I had a couple of 'similar' fuses lying around so tried one, and the machine turned on OK - i.e. the main display was working OK.

when I hit start, after the few second countdown - 'pop' again, the fuse blown, and power knocked out again.

After realising I'd have no joy with the manufacturer due to being out of warranty (they immediately suggested it would be a new controller board - around $300 AUD + $60 p/h labour) - this was an estimate, and more than the treadmill cost us) I decided to have a go myself - nothing to lose.

I did a bit of reading on this symptom, and popular opinion was talking about the bridge rectifier. I found a compatible part and ordered - ready to

fit and try again. When I removed the board to fit the component I kicked myself as I looked closer and saw the telltale 'black' around one of the

other components - (what turned out to be an STGW20NC60VD - IGBT (, so I managed to order one of those from RS Australia. Why didn't I even do that basic visual check straight away!!?

When the IGBT came I then tried to remove the existing part, but have to admit I wasn't paying close enough attention to the intricacies of the PCB at that location. Despite there being 3 pins on the component, My old soldering iron is probably way too physically big for the job and I rather hamfistedly removed the component - leaving myself with a bit of doubt of exactly what was connected to what (as there are tracks on top and bottom of the board, which would appear to have been disrupted around at least one hole in the board (the middle pin of the IGBT).

Anyway I reconnected everthing, and the outer pins were definitely connected fine. I decided to reconnect to the treadmill and give it a go (knowing the middle IGBT pin wasn't connected to the board at all - NOTE: I had no idea what an IGBT was until a few days earlier :) ).

When the treadmill was turned on again, and 'start' was pressed, there was no 'pop' this time - but an audible 'click' - presumably as some switch kicks in to fire the motor. No motor power however. I didn't investigate further whilst powered, and went back to take a closer look at the board.

It appeared that the middle pin of the IGBT 'probably' connected originally to one of the terminals on the large capacitor, as there would have been a 'tinned' edge to the original hole (which was pulled out with the original component). I was trying to logically work out the track from AC power,

through the bridge rectifier out to DC power and the motor, but it was more than an little sketchy! There was nothing else connected to the one terminal of the capacitor so it seemed a reasonable assumption.

I then got a little bit 'cowboy', and thought rather than try to pull out the component again to try to cleanly repair the middle hole, I tried to expose the copper track on the top of the board to connect the IGBT pin to the board with solder. Again my large soldering iron in these confined spaces made it a pretty shoddy job, but eventually I managed to make what seemed to be an acceptable connection to the board, and I could test continuity between the middle IGBT pin and the capacitor (with no shorts).

I reconnected the board to the treadmill, and effectively had the same experience - just a 'click' once the motor is supposed to start, but no pop.

The DV voltage at the terminals where the motor connects was basically 0v, so despite best efforts, the DC power was obviously not connecting.

Again - I'm not sure why I didn't look more closely after the first reconnect, but I looked closer again this time whilst the controller was trying to start the motor and there were several LED's on, with one flashing as it was evidently attempting to start the motor. This flashed for several seconds before stopping, and a red LED appeared - presumably to signify some sort of error. The display on the treadmill just reads 'Err' at that point. Whether it did this before reconnecting to the capacitor I don't know.

I've seen in other posts on this site about SCR's and other components (I believe the component directly next to the IGBT I replaced is an SCR) - but I'm kindof past the end of what I know here. I guess my immediate options are:

1. Also replace the bridge rectifier and try again.
2. Locate an SCR replacement part and speculatively replace that
3. Something else to simply troubleshoot what's actually going on - where the power is 'stopping' ? I don't have an oscilloscope, and just have a basic multimeter, which I'm not too confident about just 'jabbing' into the middle of a 240V circuit willy nilly. If anyone can help me continue this little crusade I would be most grateful.

Also if there are any people out there able or willing to look at / repair such a board for a reasonable fee (see the fees above I obviously wasn't willing to pay) - then I'd also certainly consider that. I guess that's the silver medal - the gold will be fixing it myself :)

Thanks so much for reading.



Joined Jul 9, 2011
I recommend drawing the schematic of at least the power part, main capacitors, bridge rectifier, IGBT, SCR (if it is one), where the pulses from the IGBT come from etc.

For a true troubleshoot job a power supply with current limiting feature would be helpful and an oscilloscope which you don't have.

Unless somebody has experience with this particular board it would be helpful for us if you can find a schematic or draw one (not all of it, just the power part).

You can also look for any suspect solder joints. see some examples here:

Thread Starter


Joined Feb 10, 2012
OK - so I thought I'd follow up on this. I ripped out the board again, and realised that when I'd re-installed it to test last time, my dodgy connection was broken.

Today, I retried to connect the middle pin of the IGBT to the capacitor track, and after reaching what seems a reasonable connection, I reinstalled again.

It worked! I am over the moon,as I was fully expecting I'd have to start replacing other components.

In the end, one component blew, and needed replacing - the meal made of the rest was really due to my inexperience.

Hope this gives someone like me a bit of hope in the future :)


Joined Jul 9, 2011
Glad it worked. I hope it doesn't burn again , there was probably a reason for it... :cool:

Bad solder joints, dried out heat compound, etc.


Joined Sep 30, 2017
Hi I have the same situation as you had, I bought a secondhand healthstream elite and I am having the same problems you had. Motor is working and power is going to the fuse but nothing in between. How did you get you treadmill working