Transformer ID Help

Discussion in 'Electronics Resources' started by SpiderSpartanju, Jul 16, 2012.

  1. SpiderSpartanju

    Thread Starter Well-Known Member

    Apr 10, 2009
    I know this might be a long shot, but I'm trying to ID a transformer that looks like it's blown. This is on an Allen Bradley 1606XL, 24V 10A power supply. I opened the box and replaced a blown fuze, which instantly blew upon applying the standard 120V AC input, and yes the input selector was set to 115V. I've tried googling the markings I can see on the transformer. It looks like ETD44 on the top is the size of the package. There's a barcode on top which must be something internal to the manufacturer. There's a sticker on the side which has a PULS logo, which is a DIN rail power supply manufacturer, that makes me think these power supplies may just be re-branded by Allen Bradley. Other than that I have not been able to find any information by googling the numbers on this sticker. There are numbers on the side which have not turned up any fruitful results either. I've tried to do some testing with my multimeter, but can't really make heads or tails of the way it's supposed to be since it looks like at least some of the windings on the transformer are shorted. I've posted links to some pictures I took of this. Thanks for any help or guidance on this.

  2. BSomer


    Dec 28, 2011
    Now I could be wrong on this statement, but from the pictures the transformer doesn't look bad. From my past experiences the transformers that I have seen go bad generally have turned a different color from too much heat or the outer insulation material is burned. Can you remove the transformer from the circuit board and test it with your ohmmeter?

    Doing a quick google search says that that power supply is a SMPS. So that transformer is not your typical power transformer, which can make it more difficult to source. Another thing is that switch mode power supplies can sometimes be difficult to troubleshoot.

    Things to check with your multimeter starting at the input:
    Filters, Rectifier, MOSFETs around transformer.
  3. szhighstar


    Jun 26, 2012
    sorry, can not open these photoes attached, I still advise you try to get datasheet of transformer, transformer was maybe customized.
  4. strantor

    AAC Fanatic!

    Oct 3, 2010
    I don't see one, but check for a shorted varistor if the transformer isn't the problem.
  5. panic mode

    Senior Member

    Oct 10, 2011
    that transformer looks healthy. if it was burned, you would smell it from other room and it would not be pretty yellow, it would be dark brown and charred.

    i would start by checking for MOV and TVSS, then semiconductors (diodes, transistors) and resistors. when capacitors blow, they either explode or inflate the top of their aluminium can bad ones are usually easy to spot.

    if the supply was connected to 220VAC when jumpered for 120VAC, there are few things that tend to go first. for example look for MOV: Products&MER=PPSO_N_P_VaristorsAndMOVs_None
    or TVSS:

    TVSS devices look like a diode (through hole or SMD) and when killed they act as a short circuit (which is used as advantage to kill another sacrificial component such as fuse of resistor and save the rest of the board). I repaired couple of Allen Bradley PLC power supplies (victims of same kind of neglect) and usually it was one power resistor and small surge suppressor.
  6. SpiderSpartanju

    Thread Starter Well-Known Member

    Apr 10, 2009
    Thanks for all the responses and sorry for the delay in getting back on this. Things have been a little crazy lately. I couldn't find any shorted varistors on the board and there is some what looks to me like light burn marks on the one side of the transformer. I did find what looks like a power resistor on the board that appears to be shorted, but it's kind of stuck back in a corner where two boards come together at 90 degrees. I'll have to try and pull the transformer and that resistor from the board when I get a chance to see if I can figure out what really has failed. I'll post back when I get a chance to dig deeper.