SUCCESS STORIES: Yamaha Keyboard P-95 sound problem (speakers & headphones)

Lehrerin

Joined Oct 14, 2018
4
Can you please tell me where you bought the c216 and c217 capacitors, because I can't find it any place. The brand is JH - 16v 100pU, but that is just 0-google match. Neither do I know if I can by some similar from another brand.

Thanks...
I didn't purchase them. I actually took my keyboard to a local music store, and they fixed it for me.
 

Outof

Joined Nov 18, 2018
4
Hello

I can now confirm, that I fixed the sound problem with replacing the two mentioned components. Thank you for leading me in the right direction, it shure fixed the problem.

Best
 
Hello - I wonder if I can use the collective wisdom from this thread to help me with the same problem. I have a Yamaha P-95 that exhibits the same behavior as those in this thread: There is no sound in the headphones or speakers, there is power, I hear clicking when plugging/unplugging the headphones. I’ve been watching this thread for a few months off and on, and have had my piano disassembled for trouble shooting during that time. The holidays finally gave me time to sink into it. I bought capacitors and replaced C216 and C217 on the AM board, but sadly that didn’t do the trick. I’m not knowledgeable about capacitors but from what I could tell the original ones and the new ones were both functional. I desoldered them to see if any sound would work with them out of the picture altogether (it didn’t). Any other ideas of how to isolate the issue? I feel like I must be so close!
 

Attachments

Resolution to my problem:
As I mentioned above, replacing the C216 and C217 capacitors on the AM board (twice) didn't do the trick. I understand that it's worked for lots of people, but it didn't work for me. I think I've seen some other posts in this thread or similar threads where it didn't work either. Since I didn't have any other suggestions or knowledge I took it to a local keyboard shop for repair. They replaced 402 and 408 on the AM board and 401 and 402 on the DM board, and now it works. They returned the replaced hardware/capacitors in a little bag, and only one of them looked like the type of capacitor for the C216 or C217 locations (but smaller). Basically I would've had trouble finding the replacement parts and wouldn't have stumbled into the right way to diagnose the problem, so for me it was a good investment to get my piano back. The total charge (parts, bench charge, and 1-1/2 hours of labor) amounted to $147.16, well worth it for how much time my kids have played with it since getting fixed. Hope this information helps someone else out in the future.
 
Hello

I can now confirm, that I fixed the sound problem with replacing the two mentioned components. Thank you for leading me in the right direction, it shure fixed the problem.

Best
Do you end up taking it to a music store? I frequently solder at my job, but I have no idea where I can purchase the correct capacitor.
 
I was able to buy the capacitor I needed as part of a set from Amazon. I compared the specs on the capacitor I wanted to replace with what was listed in the set. Was trying to replace C216 and C217, so I searched "Electrolytic Capacitor." I then made sure it had a couple with the rating 16V 100µf.
 
Hello everyone, and a warm thank you from Australia.
I have followed this thread for over a year but in total I have procrastinated in fixing my P-95B for around two years (slack I know).
All I can say is I thank you collectively for all your help, knowledge and advise (if anyone is still following this topic??).

However, the Issue I have is the same as all of you folk initially had which is "I have No Sound".
I recently opened the case to find all the boards in pretty good shape (no burns, no brown smells or leakage from any component).
I did get the relay click when plugging in the headphone jack but no joy, also no luck disconnecting this HP Circuit board from the AM board.
I then swapped around the C217 and C216 EC's, still no sound. I even swapped these out with positions with C404 and C408 as they are the same spec'd capacitors. however, still no sound.

Last week I finally got out of the house and sent it to a shop... they said its the DM Circuit board which will cost over $500 (i assume complete board swap from yamaha and outrageous labour fees).

As I find this to be a bit too expensive and already written the piano off..(considering I can buy a second hand one at that price) i may as well pick it up from the shop and keep investigating and tinkering until its fixed.

So my plan will be to BUY NEW EC for positions C216 and C217 on the AM board and also slowly aquire and change the 401 and 402 CC's on the DM C board as mention above by "southernfool". Is this correct @southernfool would you happen to have pics of those old broken bits to confirm.

C401 - WG251600 Ceramic Capacitor (chip) 4.7 6.3V K RECT
C402 - US035100 Ceramic Capacitor-B (chip) 4.7 6.3V K RECT

Has anyone else got anything else to add? before I de-solder the entire board??? I will try to keep the community updated on any progress..
 

parkwhf

Joined Jul 11, 2018
5
@frankboston I've been following this thread and your reply because I have the same problem. Have you had any luck with the repair?

Personally have just tried replacing C216 and C217 EC's to no avail. I am right back at square one with no sound out of speakers or headphones, but power/lights/controls seeming to work fine. Getting a click a few seconds after powering on and when plugging/unplugging headphones.

Wondering if @southernfool 's reported solution of replacing 402 / 408 on the AM board and 401 / 402 on the DM board has indeed worked for you since your last post. Any updates from your troubleshooting would be really appreciated.

Also, these are the EC's I purchased to replace C216, C217. Could somebody confirm for me these are the right specs and I didn't replace them with something completely wrong? Thanks.
 

Attachments

I have the parts that were traded out and took pictures of each one, see attached

@southernfool would you happen to have pics of those old broken bits to confirm.

C401 - WG251600 Ceramic Capacitor (chip) 4.7 6.3V K RECT
C402 - US035100 Ceramic Capacitor-B (chip) 4.7 6.3V K RECT
 

Attachments

bbp425

Joined May 6, 2019
1
Hello, thank you so much for your post, I had the same issue which my Yamaha P95 has no sound coming out from the speaker and the headphone output also had no sound. I did hear click sound when inserting and removing the headset. I had power in the piano. I started to disassemble the piano. I found this tutorial which is very useful:

I measured my c216 to be a short circuit component and just to double check the capacitor next to it and it was working fine. Note that I desoldered one leg from the capacitor to check just to be sure. I changed out just that c216 capacitor and the problem got resolved in one shot. Thank you so much for doing the thorough diagnosis which led me to identify that faulty capacitor and got the issue resolved.
 

mbrenco

Joined Apr 14, 2019
3
Hello everybody!
This first post of mine is to thank all people who faced this issue with a P95, and took the tiime to describe their solutions. In my case the capacitor in trouble was C112. These posts let me understand that the electrolytic capacitors are the weak components of the AM board. I used a tester on all capacitors on the board until I found that C112 was a short circuit.
I desoldered it, I'm still waiting for the replacement from Amazon, but the keyboard already works. Maybe because that capacitor is used as a safety for voltage peaks on pin 2 of the power amp, but this is just my guess.
So, thank you, and I hope my post can help someone else: before trying anything else, test the capacitors!
Marco
 

MisterBill2

Joined Jan 23, 2018
11,605
Electrolytic capacitors are the weak point on a huge number of boards, from pocket radios to TV sets and computer monitors. The cheap ones are not very good and the good ones are far from cheap.
 

Graysonmcc

Joined May 16, 2019
1
I know this is an old thread, but I'm currently having the same issue as the rest of y'all. When troubleshooting, do y'all continuously plug and unplug the ribbon connectors? I'm afraid I'm going to start damaging them soon if I keep it up. Other than that I'm going to replace the C216/217 to see if it's the issue.

I wish I knew what all of this stuff was really about. I'm a mechanic so know a little about electricity, but this is my first experience with an intricate circuit board system like this.
 

mbrenco

Joined Apr 14, 2019
3
I know this is an old thread, but I'm currently having the same issue as the rest of y'all. When troubleshooting, do y'all continuously plug and unplug the ribbon connectors? I'm afraid I'm going to start damaging them soon if I keep it up. Other than that I'm going to replace the C216/217 to see if it's the issue.

I wish I knew what all of this stuff was really about. I'm a mechanic so know a little about electricity, but this is my first experience with an intricate circuit board system like this.
Hello Greysonmcc,
I suggest to take a tester and verify which capacitor has the issue. Different people here had issues with different capacitor. You don't need to unplug anything except the power supply.
If you don't own a tester purchase one, it's worth its money!
Put the tester in the mode used to measure resistance. Then connect it to the capacitor's wires, one by one. Except for the first peak, a working capacitor should behave for the tester as an open circuit (infinite or very high resistance). If the capacitor has become a short circuit you should measure its resistance as < 100 Ohm.
Of course when the capacitors are still connected to a board the other component may interfere with your measurement, but according to the tests I did this doesn't happen on the AM board of the P95.
Hope this helps.
Marco
 
Another one with the same issue.
I however took mine into the local musical instrument shop for them to take a look.
I got a quote of £259 - For a new board.

So I'm going to try and have a stab at this myself.
I have a tester, and all the soldering equipment.

Does anyone recommend somewhere in the UK to buy the C216/217 capacitors mentioned?

Thanks.
 

mbrenco

Joined Apr 14, 2019
3
Another one with the same issue.
I however took mine into the local musical instrument shop for them to take a look.
I got a quote of £259 - For a new board.

So I'm going to try and have a stab at this myself.
I have a tester, and all the soldering equipment.

Does anyone recommend somewhere in the UK to buy the C216/217 capacitors mentioned?

Thanks.
I've found my replacement in Amazon, a set of 100 capacitors for 10 euros. They won't look exactly the same but as long as voltage and capacity are the same they are good.
 
Top