SMPS Simulation

Discussion in 'The Projects Forum' started by leafar28, Jan 30, 2013.

  1. leafar28

    Thread Starter New Member

    Jan 30, 2013
    Hi everyone.

    I'm trying to simulate this circuit, but I'm getting no good results.

    I'm using Pspice and Isis Proteus simulators.

    The problem is that Vout isnt 5V, in Pspice i got 11,3V and in Proteus I got 11,7V.

    You guys can see below a print of these simulations.

    Pspice -
    I got a msg on Pspice: WARNING [NET0076] Connection to unmodeled pin U1 pin 'CS', its about Pin 7 of 34063 IC.

    Proteus -

    Can you guys help me?


    I realize that if i take out the Pin 7 connection, nothing changed.


    Is Pin_7 only to read?

    I took out the IC and i got the same result... Something is really wrong... Can someone help me? :(
    Last edited: Jan 30, 2013
  2. thatoneguy

    AAC Fanatic!

    Feb 19, 2009
    Has anybody used an N-MOSFET or P-MOSFET as the switching unit in a circuit similar to the OP?

    I don't have Proteus, LTSpice IV is the standard simulator by many here, some use Multisim as well.
  3. THE_RB

    AAC Fanatic!

    Feb 11, 2008
    Sorry I don't use either of those simulators and can't offer a lot of help.

    However the circuit shown here DOES work, it is based on the IC datasheet "proper" buck circuit, and has been thoroughly tested and the parts values tuned for best performance. :)

    That sounds like a problem with your simulator. Pin 7 is not "unmodeled" it is a very important pin used for the current limiting!

    Maybe someone with more experience with those simulators can suggest how to fix it, but many people will not read this section of the forum as it is only for finished projects.

    If you don't get help here you could post a thread asking for help in "The Projects Forum" which has a lot more people reading it as it is for projects being worked on and project problems.

    (edit) Thank you moderators for moving these posts out of my project into their own thread.
    Last edited: Feb 1, 2013
  4. leafar28

    Thread Starter New Member

    Jan 30, 2013
    Do you use any simulator?

    If I change the IC for a Pulse Generator, that should works, right? I'm asking this because I did it, but i got the same result, so now i think the problem isnt the IC, but the PFET of the simulator.
  5. Wendy


    Mar 24, 2008
  6. THE_RB

    AAC Fanatic!

    Feb 11, 2008
    Nope, I can solder real parts about as quick, or quick enough for me. ;)

    Well the error message you said above about pin7 definitely seems to be a problem with the simulator version of the 34063 IC.

    If you still have problems even when using a pulse generator to drive the FET, that is a second problem. Did you connect the PFET pins the right way around?

    If you post some GIF screenshots of the simulator voltage waveforms on the PFET gate pin and drain pin (the one connected to the inductor) we can quickly see if the PFET is being turned on and off correctly.