SimCom SIM7100E GSM Modem Internet Connection Issue

Thread Starter


Joined Oct 16, 2017

I am using SimCom SIM7100E modem. I have tested it for GSM and SMS successfully. Then, I have also tested it for internet connection, namely SMTP, POP3, HTTP, HTTPS, FTP, FTPS, GPRS, 3G, 4G, etc.. However, I got some errors while doing Internet Connection tests.

I opened the network (i.e. being client). I took an IP address from network, (it returns when I check it with AT commands), so I assume that I have correctly established Internet and Link Layers. I have also establish the Application Layer, i.e. SMTP, HTTP, etc.. However, when I open network and try to send an email, I took response "Server Error". Hence I think I cannot establish my TCPIP layer.

Indeed, I tried to use both transparent(data) and non-transparent(command) modes. I assume that I have to provide following 2 steps for internet connection on this module.
  • In the first step, I have to use non-transparent mode for Internet Configuration (When I select this mode, I could use any AT command i.e. SMTP or any other AT Commands. However, I could not send or receive data in this mode.)
  • In the second step, namely transparent mode, I could send or receive any data. However, I could not use any SMTP configuration commands, or even enter any AT commands. When I try to send email, it gives no response.
Then, I have to turn back to the non-transparent mode in order to control the other modem jobs.

Hence, I should configure it for being both transparent mode and nontransparent mode; as being client.

I have studied the Internet Service Application Note, HTTP Application Note, FTP Application Note, Email Application Note ,TCPIP Application Note and also AT Command Manual for SIM7100E. However, these sources do not have any example code from beggining to the end of a GPRS, 3G, or LTE connection thru application layer.

I have also studied other SIMCOM GSM modules, indeed they had some example codes, but since Command Sets are different than SIM7100 and architecture are different, I could not use them.

How could I use the Command set of SMTP, HTTP or FTP etc. with this GSM modem and make a full internet connection? Is there any code examples, or a ordered list of the commands in order to help me to connect internet? What is your opinion? What should I do, in order to just use the modem as I use like in a mobile phone internet?

Best Regards


Thread Starter


Joined Oct 16, 2017
You may consider this as another modem which you well know, and is there any mistake with my steps? I could try to modify your solution according to my modem AT command set if you could give any opinion.

In more detail, I do the following steps in the given order:
  • External PPP Setting i.e. AT+CGDCONT=1,"IP","internet" according to my ISP
  • I ensure GPRS network is available before TCPIP setup since TCPIP application is based on GPRS network
  • I enable PDP Context i.e. AT+CGSOCKCONT=1,"IP","internet"
  • AT+CIPMODE=0 (command mode)
  • As for being TCP client, I write AT+CIPOPEN=0,"TCP","",80 (I want to access the home page of google for test, Hence I choose in order to make a TCP connection between google server and my modem)
  • Then, since I want to get the html web page from I write AT+CHTTPACT="",80
  • I input the HTTP request i.e. GET /index.html HTTP/1.1
  • In order to indicate end of the HTTP request data, I write <CTRL+Z> in hexadecimal mode (according to the datasheet)
Until now, if you read carrefully, you might have notice that I did not entered data mode yet. This is because I ignored to enter data mode, since I have tried to enter the data mode in every steps between the upper steps, but I could not enter any AT command and receive any data while doing that. After the last step, I close TCP connection and other opened things.
As I said before, I took an IP adress, I do every required checks before and after the upper steps. But after I have done any Application Layer steps, I took a "Server Error". (and sometimes the error code 227, which is the error code of "Network Error". And also my SIM card has enough data, dial and sms packages from my ISP.

Thank you for your answers!


Joined Dec 4, 2017

I am trying to use HTTP POST and GET commands after the I establish the HTTP connection successfully, but I am also getting error CHTTPACT: 227. I have also tried all the above commands posted above before communicating with the server, but could not get through successfully. Please let me know if you have got the solution of this.