Serious LTSPice Timestep too Small

Discussion in 'General Electronics Chat' started by kingneb, Nov 4, 2012.

  1. kingneb

    Thread Starter New Member

    Nov 4, 2012

    I having an extremely frustrating issue with LTSpice. It is a full tube amplifier, power supply, rectifier diodes and all.

    About 14mS into simulation it crashed with a timestep too small error. No matter what action I take, whether it be changing around components, messing with settings, etc does not correct the issue. I am about ready to scream :mad:

    Can someone please take a look at my circuit to see what I am doing and/or not doing? It is attached in the zip file.

  2. crutschow


    Mar 14, 2008
    Spice simulators often generate "timestep too small" errors and the cause is usually not apparent.

    Try going to the "Control Panel" under "Simulate" and select the "SPICE" tab.

    First try "Gear" or "trapezoidal" on the left to see if that helps.

    If not, then increase the value of the items on the right by one order of magnitude (except for Trtol) e.g. if its 1e-012, change to 1e-011. That will reduce the simulation accuracy somewhat, but may solve your problem.
  3. Papabravo


    Feb 24, 2006
    Check to make sure that your circuit has a well defined ground node.
  4. Ron H

    AAC Fanatic!

    Apr 14, 2005
    I simulated his circuit, with the same results. The weird thing is it identifies the problem as being associated with D9. If you take that power supply circuit and copy it to another page, then simulate just that, it runs just fine.
    I tried changing D7 and D9 to 1N4007, and it still hung up with the same error.
    It hangs with Gear also.
    In the original ckt, I tried replacing the rectifier and zener in the grid bias power supply with a -72.5V battery, and the problem moved to D4. I replaced THAT rectifier ckt with a 535V battery, and the circuit finally ran OK.
    Maybe the OP should simulate the amplifier and the power supplies separately.
    Another benefit is you shouldn't have to run the amplifier sim for 6 seconds, if you use batteries as power supplies. It is painfully slow, even without the 1us minimum time step.