Repairing a Tact Switch

Thread Starter

lothian1

Joined Jan 6, 2021
3
I've confirmed tact switch in the image isn't working. I figure I'd simply replace the thing, but it seems affixed with unobtainium solder--the stuff just won't liquify. I'm considering cutting its leads and replacing it with a surface-mount equivalent. It occurred to me that perhaps a soak in a solvent-based cleaner might work?

Anyone have tips for removing these diminutive components? How about performing necromancy on seemingly dead switches (i.e., likely corroded contact)IMG_0695.jpg?
 

bertus

Joined Apr 5, 2008
21,589
Hello,

Have you confirmed all connections?
switch_connections.png

As you can see there two pairs of pins connected together with a switch in between.

Bertus
 

Thread Starter

lothian1

Joined Jan 6, 2021
3
yup--I confirmed (all) the connections.

For grins I dissected the thing in situ, cleaned the contacts and the underside of the diaphragm doohickey with solvent, reassembled and... voila... the switch works perfectly. corrosion was suspected; corrosion is confirmed.

a buddy has a set of orthodontists tools. i'll borrow his side cutters and nip this thing from the pcb. i've never bought a tactile switch before--i presume i'll have to order its replacement based on dimensions, mount-type, and pole.
 
Last edited:

Lo_volt

Joined Apr 3, 2014
229
Is it just one or two of the pins that doesn't melt or all of them? It's possible that one or two of the pins is connected to a ground plane on the PC board. The ground plane is an expanse of copper that may sink heat away faster than your soldering iron can heat. They are notoriously hard to solder and de-solder.

I'll second AlbertHall's suggestion to cut the pins and de-solder them one at a time. You may not be able to heat all of them at once, but one at a time should work.
 
Top