Program downloading error

Discussion in 'Embedded Systems and Microcontrollers' started by rabhishek91, May 7, 2013.

  1. rabhishek91

    Thread Starter Member

    Feb 14, 2013
    Hi everyone.:)
    I am using Ponyser SPI programmer to program ATmega32 via Ponyprog software.

    First, i tried in my laptop interfacing the programmer ( via USB to RS232 converter). It didn't work [Somewhere in the internet i read that it is damn slow]

    So i decided to do my work in desktop. I connected RS232 cable to its port, selected the respective COM port and tried programming . I got the following error.:confused:
    "Device missing or Unknown device". I have attached the screenshot for reference.

    This is my first attempt of downloading the program onto MUC. Please correct my mistakes.
    Thanks in advance.
  2. kubeek


    Sep 20, 2005
    First thing, check that your serial is not used by something else, then in setup click probe and check the software recognizes your serial adapter. Are you sure you have the connections right?
    Usb to 232 is slow, takes maybe half a minute to load a program, but it should work if your adapter has the control lines and not just rx and tx.
    Also, the thing is called SI Prog, not ponyser.
    Last edited: May 7, 2013
  3. tshuck

    Well-Known Member

    Oct 18, 2012
    Hopefully, you didn't connect directly from the serial port to the microcontroller, those voltages will kill it.

    Atmel chips aren't programmed through UART, they ate programmed through SPI. A bootloader is required to program via UART.