Problems with PicKit 2

Discussion in 'Embedded Systems and Microcontrollers' started by powzoom, Jan 14, 2010.

  1. powzoom

    Thread Starter Active Member

    Jan 18, 2009
    I have the picKit 2 and it works... with some chips. I've been using the pic16F688 device and it has been working fine. However, when I plug in a dsPIC33J12MC201 (why are the names so long?) or a PIC24F08KA101 I get an error in MPLAB saying

    PKWarn0003: Unexpected device ID: Please verify that a dsPIC33FJ12MC201 is correctly installed in the application. (Expected ID = 0x8000000, ID Read = 0x0)
    PK2Error0049: VPP Voltage error. Check target and retry operation.

    I get a similar voltage error when I try the pickit software. Also the same error when I try the other pic24 chip. It seems that it is not recognizing the devices at all (Read 0x0). I have no idea why.

    The pickit 2 supported devices list lists both chips as compatible with both MPLAB and Pickit2 software yet it doesn't work on either.
  2. maxpower097

    Well-Known Member

    Feb 20, 2009
    Is it a clone or a genuine PK2?
  3. spinnaker

    AAC Fanatic!

    Oct 29, 2009
    Are you sure your PICS are any good? Are you sure the chips are being powered?
  4. powzoom

    Thread Starter Active Member

    Jan 18, 2009
    It is a real pickit2 ordered from mircochip with the 20 pin development board. I've tried providing power to the pics with my own power source. The pickkit and matlab software both first read the voltage, say its 3.3, say that's in range, then it says it can't connect and there is no voltage. The pics I'm using should be fine. They are still in the tubes that microchip sent and stored next to the 16f688 wich works fine. I even took the pic at the end of the tube which hasn't ever been touched and the same problem persists.

    I've ordered 2 different types of chips, one being the 16F690 which now comes with the pickit2. So I'll see if those work when they get here.
  5. bertus


    Apr 5, 2008
  6. raviypujar

    New Member

    May 20, 2012
    My PICKIT2 is also giving the same problem and i got a solution for it check my blog