photodiode circuit: NEED HELP

Thread Starter

pougetp

Joined Jul 12, 2008
27
Hi,

I'm trying to make a circuit to detect a white flash on screen tV.. and to send a TTL for each flash (60Hz monitor).
Attached the circuit I'm working on... not working :mad:.... I spent the last two days... I do not know what is wrong with it.

I really need help there....:eek:

Thanks a lot

pierre
 

Attachments

bertus

Joined Apr 5, 2008
20,653
Hello,

Can you make a schematic in stead of a wiring diagram.
The picture may be some bit larger, this one is very hard to read.

Greetings,
Bertus
 

bertus

Joined Apr 5, 2008
20,653
Hello,

What happens on pin 12 of the UA747?
What is the voltage in this pin when there is light and no light?

Greetings,
Bertus
 

Thread Starter

pougetp

Joined Jul 12, 2008
27
Ok Bertus,

I'm preparing the system and will do the measurement.
So far the 123N is hot when we plug the circuit.
We REALLY appreciate your help.
I'm sending the measure in a minute...

pierre
 

Thread Starter

pougetp

Joined Jul 12, 2008
27
The voltage is 4.5v and do not change in/out light.
We tested the photosensor is working fine we did test it.
Does the diagram sounds reasonable?

pierre
 

bertus

Joined Apr 5, 2008
20,653
Hello,

Take th 75K resistor from pin 12 and put it to the - 5 Volt.
Do the test again.

Now I see it. The 74LS123 may not have negativ voltages on an input.
You have - 5V at pin 3, this can destroy the 123.
Put this pin on ground.

Greetings,
Bertus
 
Last edited:

Thread Starter

pougetp

Joined Jul 12, 2008
27
Hi Bertus,

ok we put the pin 3 at ground...:( of the 74LS123
Still not working...
The voltage is at the UA747 is 4.5v. The 74LS123 is not warm anymore :).
We are ok to start from scratch if you think this scheme is simply wrong....

pierre
 

bertus

Joined Apr 5, 2008
20,653
Hello,

Yes, measure with and without light on pin 12.
Also measure with and without light on pin 1.

Greetings,
Bertus
 

Thread Starter

pougetp

Joined Jul 12, 2008
27
:confused:....
A diagram... please help. I really need this project by next week.


:mad: should have done me electronic.

Thanks you all in advance

pierre
 

bertus

Joined Apr 5, 2008
20,653
Hello,

It looks like you phototransistor does not react at the moment.

How did you measrue with and without light?
Did you cover the phototransistor with something for the dark measurement?
Did you shine with a light on it for the light measurement?

Greetings,
Bertus
 

Thread Starter

pougetp

Joined Jul 12, 2008
27
:)
ok I did put the diode in darkness.
Now pin 1: is changing from +5.. 2v
But pin 12 is not changing at all: 3.25v

Thanks again Bertus for all your effort... I really hope we can fix it

pierre
 

bertus

Joined Apr 5, 2008
20,653
Hello,

Take the potentiometer from pin 7 to pin 2 (take the ground off).
Take the potentiometer from ground and put it to + 5 Volt.
Now you can put pin 2 to about 4 Volts with the potentiometer.
Do the light and dark measurements again on pin 1 and 12 of the 747.

Greetings,
Bertus
 

Thread Starter

pougetp

Joined Jul 12, 2008
27
*
*Take the potentiometer from pin 7 to pin 2 (take the ground off).

we've got 0.2v between pin 7 and 2 after taking ground off (from pin 2)

*Take the potentiometer from ground and put it to + 5 Volt.

ok we took the ground of the potentiometer off
and put it to the +5v

*Now you can put pin 2 to about 4 Volts with the potentiometer.
ok we put 4volt between pin 2 and 7 by adjusting the potentiometer.
The potentiometer is still connected to pin 7, +5 and -5

*Do the light and dark measurements again on pin 1 and 12 of the 747.
now pin 1 is 5v but no change with light
and pin 12 is 3.25 with no change with light.


pierre
 

Thread Starter

pougetp

Joined Jul 12, 2008
27
after more measures
and a disconnected wire:mad:
pin 1 is varying from 1.25 to 3.5 dark to light
pin 12 is very varying but very small change from 3.25 to 3.18 with very bright light.

pierre
 
Top