Philips HTS3544/37 Circuit Board Help

Thread Starter

Lambojoey

Joined Jun 25, 2012
10
Hello Everyone!
I have a question of possible motives that would stop a power supply to work intermittently.

I have a Phillips Home entertainment system that I rarely use. The problem seems to be to somewhere in the power supply. It works for a few weeks/months and then it stops. The standby/power light won’t light up and the unit is dead. I removed the cover and I hear something trying to start up for a split second then it stops. The fuse is good. The voltage to the unit is also okay. I took it apart last night and look for obvious signs of damage but there wasn’t any. I come home this afternoon and it powers up like normally.

I was advised to check the transistors on the board when it’s not working. Does anyone have a plan of attack that might help solve this problem or has anyone ever had a similar experience with a power supply board?

Thanks for any help.
 

MrChips

Joined Oct 2, 2009
30,974
Good. Since you have already been inside the unit you have access to the circuit board.
What test equipment do you have? DVM? Scope?
 

MrChips

Joined Oct 2, 2009
30,974
That's OK. We will work on the assumption that the problem is in the power supply.
I have the schematic in front of me and we can look at some voltages.
This may take some time... and I may be busy for the next few days.
What is your local time now?
 

MrChips

Joined Oct 2, 2009
30,974
What is your level of trouble shooting expertise?
Do you want to have a go at this on your own if I send you the Service Manual?
 

Thread Starter

Lambojoey

Joined Jun 25, 2012
10
Thank you.

In my search I was told that the common areas of problems with the power supply board was Q901, Q909, Q9412, IC901, IC902.

One Question do you think the voltage will actually be significantly different since its operating properly at this moment.
 

Thread Starter

Lambojoey

Joined Jun 25, 2012
10
My expertise is limited but at one time I was AC repair Tech and I took apart my Lambo by myself. So while I lack experience I am pretty good a figuring things out.
 

MrChips

Joined Oct 2, 2009
30,974
No. Unfortunately, you can't fix it if it ain't broke!
You have to wait until it fails again.

You said you can hear it trying to start up. What do you hear?
Since it is a switching supply you may be hearing the oscillator. Then if a fault is found it may shut itself down. There is a possibility that the PSU is ok and maybe the problem is in the load.
 

Thread Starter

Lambojoey

Joined Jun 25, 2012
10
It is so short its hard to tell. I plug it in and the sounds gone just as fast. Once in awhile after pluging it in and out the power/standby light sometimes blinks rapidly( its dim) then it goes out. I dont hear the transformer or any other noise when its dead besides when I plug it in.


One other question. When its in Standby mode/off- (lid off) it has a high pitch screech that goes away once I turn it on... Is that normal?
 
Last edited:

MrHam

Joined Jul 20, 2012
10
Thank you MrChips, I have one of these units that just died. will not turn on. I would like the service manual to troubleshoot it, the schematic you posted is a little too pixelated to read the component designators and values.
 
Top