Orcad Pspice Probing issue "No simulation data for marker"

Discussion in 'Programmer's Corner' started by sunnybouorm, Dec 19, 2012.

  1. sunnybouorm

    Thread Starter New Member

    Dec 19, 2012

    I have attempted to search through various sources on the possible cause of my problem but no dice. I'm sure many others would have possibly experienced this same issue but i couldn't figure out the right keywords in my search.

    After a good while of pent up frustration from failing to find anything relevant, I bumped into this site via Google and decided to post on this forum.

    my pspice knowledge is not advanced, but I've done a fair bit of tutorials to cover the basics.

    I have been attempting to create a basic model to simulate an L298 IC based on whatever I can deduce from the data sheet since i couldn't find a model that's already been done.

    My problem is as follows, after creating a hierarchical block with schematic view for the L298 and attempting to probe some of the inputs from my circuit, I run the simulation and what I get as a result is the following:

    --------------- Simulation Profile: SCHEMATIC2-asdasdasadas ---------------
    Simulation running...
    No simulation data for marker ' V(HB1:EnA) '
    No simulation data for marker ' V(HB1:In2A) '
    No simulation data for marker ' V(HB1:In1A) '
    No simulation data for marker ' V(HB1:In1A) '
    No simulation data for marker ' V(HB1:OUT2B) '
    No simulation data for marker ' V(HB1:In2B) '
    No simulation data for marker ' V(HB1:EnB) '
    ** Profile: "SCHEMATIC2-asdasdasadas" [ C:\Users\sunny\Desktop\personal folder\software\engineering software\pspice\schematics\NMOS
    Reading and checking circuit
    Circuit read in and checked, no errors
    Calculating bias point for Transient Analysis
    Bias point calculated
    Transient Analysis
    Transient Analysis finished

    the simulation still runs, for instance, i can probe VS both inside and outside the block and i get 24V.

    But the voltage probes with the "No simulation data for marker" warning remain grayed out.

    I ascended down the block then tried isolating the inputs making them floating and applied 5VDC to one of the L298 block inputs to see if i get 5V inside the block as well as outside, no dice.

    In one case illustrated you can see the probe works on the 5V source but if you place the probe a little further away it gets grayed out. Also if the wire is disconnected altogether from the block then the probe works regardless of where it is placed along the wire. This has me baffled as it happens even when the input inside the block is floating.

    I tried that test while fiddling with the block's ports and synchronized the circuit properly after each change, changing the port to all configurations input, bidirectional etc... still no dice
    I tried redoing the entire circuit and reconnecting the block, no dice
    I closed the program and reopened it no dice.

    The libraries for all the components i used are from the pspice library, I also tested each component in isolation and they work fine.

    I think the problem may be a very simple one, a mistake on my behalf but I can't point my finger at it

    I made a very simple FET HBridge similar to the L298 a few days ago and used the same method to create a hierarchical block and the probes worked fine both inside and outside the block, I don't know what could be causing this to trip up on me

    I also tried doing the L298 circuit altogether in one go without the hiearchy block and everything worked fine. I can do this without the block, but i want to get it right with the block since it makes the circuit look a lot neater and less crowded

    Anything helpful and insightful would be greatly appreciated
    thank you for your time
  2. sunnybouorm

    Thread Starter New Member

    Dec 19, 2012
    strange i redid the entire project from scratch and it works fine now
  3. WBahn


    Mar 31, 2012
    I don't find that surprising. OrCAD bought MicroSim and, unless something has happened in the intervening years, has just continued to develop their schematic capture tool. From a look and feel standpoint, MicroSim schematic capture has always been, by far, my favorite. It's problem is that it is super buggy and MicroSim's management would never put any effort into fixing it, instead focusing only on feature enhancement. I dug into the format of their database one day and quickly determined that connection information is way overdefined, meaning that you could generate a netlist from multiple sets of information in the file that would produce different results unless all of that information is perfectly synched. But keeping it perfectly synched is not the easiest thing in the world, especially when the underlying software platform is bug ridden. So I have seen many times when what you see on the schematic (which is pulled from the file using one set of data) doesn't match the simulaiton netlist (which is pulled from the file using a different set of data). The only way to solve the problem (back in the day, anyway) is to redraw the schematic from scratch. If you ever see missing connection dots, you have a problem . The problems always seemed to be the worst when bus taps and sub-busses were involved.
    sunnybouorm likes this.