No current through ammeter in simple battery circuit

Discussion in 'The Projects Forum' started by GreenPenInc, Nov 21, 2007.

  1. GreenPenInc

    Thread Starter Member

    May 13, 2007
    I made a simple circuit with two regular 1.5V batteries in series, a small resistor, and an ammeter, all also in series. No matter what current setting I put my ammeter at, it wouldn't measure any current. My particular model has a poor connection, so I set it to the continuity test function and touched the ends together, adjusting the connections until I got continuity. Also, measuring voltage worked just fine, so I'm sure the lead connections to the meter aren't the problem.

    I decided I needed some other indication of whether current was flowing, so I added a small red LED in series. With no ammeter (batteries - resistor - LED), the LED lit up just fine. When I break the circuit and add the ammeter in series, it still measures no current, and the LED also stays dark, so when it says there's no current I believe it.

    Has anyone encountered anything like this? Any ideas for how I can measure current in a simple battery circuit? This is really frustrating -- I thought it would be really simple stuff.
  2. ashokcp

    Active Member

    Mar 8, 2007
    If your batteries, resistor and LED are working alone, and, they dont work with the ammeter, can you guess what could be wrong?
  3. GreenPenInc

    Thread Starter Member

    May 13, 2007
    As I said, I tested the voltage and resistance functions of my multimeter and they both worked fine. So I concluded that the multimeter as a whole was not malfunctioning.

    Now, a decently bright red LED should be drawing less than about 20 mA of current, which is consistent with the voltage drop I measured across the resistor too. This amount should show up on the 200 mA setting as well as the 20 mA setting. However, neither of them registers a current when I hook up the ammeter in series.

    My understanding of multimeters (which I gained partially from this site) told me that each separate setting connects the leads to a different subcircuit (simplistically, a different resistor). Thus, if I've verified that the leads are good, it seemed implausible that all of the current settings, and only the current settings, would be bad.

    Of course, on further reflection, I realized there was probably a larger subcircuit common to all current measurements, and that it was quite plausible for this to have gone bad. I never considered this before but now it seems like it's probably the case: my multimeter has a bad current subsystem.

    I popped off the back cover to have a look and see if I could diagnose the problem. The picture is attached; apparently, it's the Mastech MAS830L board. Unfortunately, I wasn't sure how to go about obtaining a schematic so I could see what parts to test. Not to mention, I don't have another multimeter to do the testing with!

    So here's where I'm at. Going under the assumption that the ammeter part of my DMM is bad, I've put another multimeter on my Christmas list (the Mastech DT9205 seems good; it also does capacitance and AC current measurements). In the meantime I'll keep messing around with whatever I can do without measuring currents. If I get ambitious, I'll buy the meter movement from Radio shack and make an ammeter from that (in fact, I should probably do that anyway just for fun/learning). Eventually I hope to repair this multimeter to the best of my abilities -- it'll be a fun project!

    Does my basic analysis seem correct? Also, does anyone have experience with this board to know how I can test it?

    Thanks in advance.
  4. kubeek


    Sep 20, 2005
    What about checking connection to the meter (leads in the right holes) and the fuse?
  5. techroomt

    Senior Member

    May 19, 2004
    are you using a multimeter in the amp function? i learned several years ago that 3 jack multimeters have an inaccuracy when measuring current. the instrument design engineer explained the problem being with the multifunctionality of the volt/ohm/milliamp jack having what i think i remember being called burden voltage. you can calculate the error out. so for accurate display readings of current you are better off with 4 jack meters (there is a dedicated current jack), or just a dedicated ammeter.
  6. Ron H

    AAC Fanatic!

    Apr 14, 2005
    To clarify this: In a multimeter, the current measurement function requires that you move one of the leads to (one of) the current measurement jacks. That jack will have a fuse in series with it somewhere within the multimeter. If the fuse is blown, the ammeter function will not work.
    EDIT: I see the fuse in your picture. Is it blown?
  7. beenthere

    Retired Moderator

    Apr 20, 2004
    Wrapping the fuse in aluminum foil can be useful for a function check. If the meter only reads current with the wrap, get a new fuse ASAP.
  8. GreenPenInc

    Thread Starter Member

    May 13, 2007
    Ah, I see the problem! I always thought the fuse was for everything, but apparently it's only for current measurements. That makes sense, now that I think about it. I won't have access to the DMM for another few days, when I get back from Thanksgiving, but I'm sure that must be it.

    Thanks very much for your patience and help, everybody -- can't wait to get back at it! And I feel I've learned very valuable (and humbling) lessons that will not soon be forgotten.
  9. knowitall

    New Member

    Jan 10, 2010
    Did you check the internal fuse, what usualy happends in cases like this is the multi meter was left on amps then the probes were used to measure volts, then pop, you may have to lift the pc board to find out what is the problem, What no fuse then check for a toasted large shunt resistor, still no luck? check for a fused P.C. track coming from the switch ,or the pads or P.C. traces coming fromm the selector switch, It's got to be one of the listed. the bad thing about trouble shooting a Multi-meter is you need a multi-meter to check a faulty multi-meter. Hope I helped.

  10. Ron H

    AAC Fanatic!

    Apr 14, 2005
    You have responded to a thread that is over two years old, with essentially the same information as was already posted. I have to admit I have done the same thing.
    It is advisable to read the entire thread before replying, and to check dates.
  11. hgmjr

    Retired Moderator

    Jan 28, 2005
    In addition to the thread being old, the poster has not revisited the AAC site since late 2007.