Need help with a Fluke laser thermometer

Discussion in 'General Electronics Chat' started by BluesJunkie, Jan 11, 2014.

  1. BluesJunkie

    Thread Starter New Member

    Jan 11, 2014
    I have a Fluke 62 Mini IR Thermometer. It is stuck in the hold function. You should be able to hold the trigger and scan various surfaces and the display should change with the changing temperatures. You can also have it in "hold" mode, which holds on the temp of a specific reading. It is stuck on that mode.

    When I depress he trigger the screen goes blank. When I release it it displays the temperature of the surface that was read at the time the trigger was released. I cannot scan various surfaces and watch the reading change. "Hold" is displayed in the upper right corner of the display. I have every changed the battery and can find no switch related to this.

    Am I missing something? Does anyone have a solution for this?
  2. GopherT

    AAC Fanatic!

    Nov 23, 2012
    Check the batteries.
  3. BluesJunkie

    Thread Starter New Member

    Jan 11, 2014
    The unit has not been used for some time and did not work when I tried to use it. I installed a new battery and found that it worked as described in this post.
  4. #12


    Nov 30, 2010
    This machine, being blessed with a microprocessor, you can only mess with the inputs. See if the switch is stuck or broken such that you can't change modes, and that's about all you can do except send it to Fluke for a repair.

    Oh yeah, check the circuit board for components and copper traces that might have gone bad or come loose, thus interfering with the input signal from the switch.

    Sorry to be a wet blanket, but that's the best I can do.
    Last edited: Jan 12, 2014
    GopherT likes this.