Message[310] G:\MICROCHIP\MPLAB IDE\MPASM SUITE\P16F877.INC 1006 : Superseding current maximum RAM a

Thread Starter

Givi

Joined Nov 16, 2014
5
Hi there,

I am hopping someone can help me with figuring out if this is a real issues or not "1006 : Superseding current maximum RAM and RAM map.". This is what I see after I compile and when I double Click on this message it brings up a blank page with only a number "541" on the top left hand side and nothing else. It seems it has something to do with the "P16F877.INC" File which is Included in the code on top. Below is part of the compiled messages. Should I pursue this and is there a fix for it?
Thanks.

Message[302] G:\MYPROJECT\MPLAB\I2CSONAR16C74A\XDCR.ASM 89 : Register in operand not in bank 0. Ensure that bank bits are correct.
Message[302] G:\MYPROJECT\MPLAB\I2CSONAR16C74A\XDCR.ASM 94 : Register in operand not in bank 0. Ensure that bank bits are correct.
Message[302] G:\MYPROJECT\MPLAB\I2CSONAR16C74A\XDCR.ASM 95 : Register in operand not in bank 0. Ensure that bank bits are correct.
Message[302] G:\MYPROJECT\MPLAB\I2CSONAR16C74A\XDCR.ASM 97 : Register in operand not in bank 0. Ensure that bank bits are correct.
Message[302] G:\MYPROJECT\MPLAB\I2CSONAR16C74A\XDCR.ASM 99 : Register in operand not in bank 0. Ensure that bank bits are correct.
Message[302] G:\MYPROJECT\MPLAB\I2CSONAR16C74A\XDCR.ASM 101 : Register in operand not in bank 0. Ensure that bank bits are correct.
Message[310] G:\MICROCHIP\MPLAB IDE\MPASM SUITE\P16F877.INC 1006 : Superseding current maximum RAM and RAM map.
Message[305] G:\MYPROJECT\MPLAB\I2CSONAR16C74A\XDCR.ASM 277 : Using default destination of 1 (file).
Message[305] G:\MYPROJECT\MPLAB\I2CSONAR16C74A\XDCR.ASM 279 : Using default destination of 1 (file).
Message[305] G:\MYPROJECT\MPLAB\I2CSONAR16C74A\XDCR.ASM 281 : Using default destination of 1 (file).
Executing: "G:\Microchip\MPLAB IDE\MPASM Suite\mplink.exe" /p16F877 "..
MPLINK 4.49, Linker
Device Database Version 1.14
Copyright (c) 1998-2011 Microchip Technology Inc.
Errors : 0
 

MaxHeadRoom

Joined Jul 18, 2013
23,620
Message 310 ' the _maxram directive has been used previously'.
Something conflicting in the INC file?
See the Mpasm/Mplink/Mplib Users Guide
Max.
 
Last edited:

JohnInTX

Joined Jun 26, 2012
4,554
In the INC file there is the statement __MAXRAM H'01FF'
Is there a previous definition in the program?
I wonder that, too. The reported file paths have 16C74A in them. If the OP is porting from some posted source, is MAXRAM defined in one of those files? You might try a global text search for 'maxram' CTRL-SHIFT-F will search all the files in your project. As for fixing it, I sure would. Eventually leaving loose ends like this will bite you.

One thing I do is move the Pxxxx.inc file from the MPLAB directory to the project directory and add it to the project list. That way you have more control over it and MPLAB updates won't affect already-built projects.

You can suppress the useless 302 error with ERRORLEVEL -302 at the top of the .ASM file.
Suppress the 305 error by always explicitly specifying ,F or ,W. Avoid using defaults.

Good luck.
 
Last edited:

ErnieM

Joined Apr 24, 2011
8,178
Could two (or more) files be invoking the P16F877.INC file?

It has been way too long for me to remember what works and what fails when you include an asm file twice like that, but perhaps the __MAXRAM directive cannot be changed, but the other equates are fine.
 

Thread Starter

Givi

Joined Nov 16, 2014
5
Gents,
Thank you for your input. It was my bad. I had included a wrong file by mistake. I removed the file from the project and searched for the correct file in the right path and included it in the project, which fixed the issue. It was silly.

Thank you again.


Regards,

Givi
 
Top