l297 diagnostics

Discussion in 'The Projects Forum' started by dfink, Dec 11, 2010.

  1. dfink

    Thread Starter New Member

    Dec 2, 2010
    Trying to learn about stepper motors so I assembled the l297 l298 combo as shown in the datasheets. I can turn the assembly on and off with the enable pin. Ground it and all the driver pins go to low. Set the enable pin high 5V and I get what appears to be the home state. At the l298 output 1 is low 2 is high 3 is low and 4 is high. I have tried just about every combination of the other pins but what I have read those really shouldn't make much difference for the basic operation.
    I am using the 7805 for the l297 circuit it maintains 5 volts at all times. I am using a 4.7nf capacitor for the chopper but again that shouldn't matter for the basic operation. The clock input is from a 555 timer circuit. I also tried pulling pin 18 low with a resistor but still nothing but the single state.
    Perhaps I just got a bad chip but since the oscillator is working, and pin 10 is working it seems I might be doing something wrong. Also if I pull pin 20 to ground it doesn't appear to affect the state of pin 3. From what I can gather pin 3 is an open collector so placing a pull up resistor and an LED on pin 3 I should get a light when the chip is in Home state. I should be able to force this by making pin 20 low but that does not work.
    Bad chip or am I missing something.
  2. R!f@@

    AAC Fanatic!

    Apr 2, 2009
    Yes ..what's missing is ur attitude.
  3. nomurphy

    AAC Fanatic!

    Aug 8, 2005
    I don't see anything wrong with your attitude, but trying to follow your explanation is pretty useless without a schematic representation.
  4. dfink

    Thread Starter New Member

    Dec 2, 2010
    Sorry I didn't post the schematic it is here. I don't have a way to draw my own.
    Signal from 555 timer goes to pin 18
    Pin 15 controlled with 100K pot can be set from 0 to 5V makes no difference
    I have 12V to motor
    I have 5V to control circuit provided by 7805 it is stable at 5V
    I have a signal being generated by the l297 at the sync pin
    If I force pin 10 low ground then pins 4679 all disable and go low
    If I remove pin 10 from ground then pins 4 low 6 high 7 low and 9 High that I believe is home position
    That is all it does
    The circuit itself should be fine. I am just looking for an opinion on the operation of the l297 as I have never used one. With the basic configuration shouldn't pins 4679 do something when a 0-5V clock signal is applied to pin 18 and pin 10 is pulled high

  5. hgmjr

    Retired Moderator

    Jan 28, 2005
    Are you certain that you are using a bipolar stepper motor and not a unipolar stepper motor?

  6. SgtWookie


    Jul 17, 2007
    A 5-lead , 6-lead or 8-lead stepper can be used as either a unipolar or bipolar stepper with the right connections.

    Some 4-wire steppers are not bipolar, they're 3-phase or BLDC (brushless DC) motors.

    However, our OP seems to be experiencing problems with the L297/L298 combination, not the motor itself, as they don't seem to be able to get the L298 output to change despite clocking the L297 input.

    1) Connect pin 3 to +5v using a 1k resistor. If pin 3 then measures 5v, the L297 is in "HOME" state.

    2) Leave pin 1 (SYNC) disconnected.

    3) Connect pin 10 (ENABLE) to +5v.

    4) Connect pin 11 (CONTROL) to ground.

    5) Pin 15's connections require a bit of calculating; you need to establish a voltage reference that will determine when the chopper driver kicks in. What is the current rating of your stepper motor?

    If Rsense1 and 2 are both 0.5 Ohm resistors, then Vref (voltage on pin 15) will need to be low enough to limit the current on the L298 bridge. I suggest staying below 2 Amperes current through the bridge even if you have really good heat sinking, as the bridge will drop around 4.5v across itself, so will have around 9 Watts of power dissipation with 2A current flow.

    If Rsense = 0.5v, then setting Vref to 1v will limit the current to 2A; setting Vref to 0.5v limits the current to 1A.

    6) Connect pin 17 to +5v for CW operation, ground for CCW operation.

    7) Pin 18 CLOCK\ input - if you're powering the 555 timer from 5v, it's output swing will be from nearly 0v to +5v-~1.3v, or 3.7v. 3.7v is normally high enough to be considered a logic 1, but it might not be enough for the L297, I don't know offhand.

    If you are driving pin 18 from pin 3 of a 555 timer, you might try connecting a 330 Ohm resistor from +5v to pin 18 to act as a pull-up resistor. This should give the 555 timer nearly a full ~0.1v to ~4.9v output swing.

    8) Connect pin 19 to ground (HALF/FULL\) while troubleshooting to select full step operation.

    9) Connect pin 20 to +5v. If it is low, the L297 will stay reset with the 0101 output.
  7. dfink

    Thread Starter New Member

    Dec 2, 2010
    Well I finally pulled the chip from the board and put on a breadboard so I could eliminate some of the variables. Even in it's most basic form with the sense pins disabled to ground, the enable pin high, the v ref pin high, the reset pin high, I still get the same results. At this point I believe the chip is at fault and will order a replacement. If it doesn't work either then I will have to pursue further.
  8. R!f@@

    AAC Fanatic!

    Apr 2, 2009
    See...That's the problem...
    I went with that and I blew more eyes than I hoped for..Umm! IC's, I mean.

    Finally I went with Sgt's idea...I think you should do the same OP