Kiln won't heat when hooked to controller

Discussion in 'General Electronics Chat' started by jeweler, Nov 23, 2011.

  1. jeweler

    Thread Starter New Member

    Nov 23, 2011
    I have a kiln I use to burn wax out of molds for lost wax casting. It is connected to an electronic controller that controls the temperature of the kiln and how long it heats and how long it holds at the set temperatures. It has worked well until recently. Now the kiln is completely dead when plugged into the controller. I sent the controller to be repaired but after testing was told it is operating properly, so it must be something in the kiln. The kiln fires up and heats when plugged into a wall socket. So I am mystified, as are the repair people I have been talking to. The controller hooks into the kiln pyrometer, which controls the heat. There is a thermometer on the kiln that shows the temperature. This seems to be working okay. Does anyone have any theories on why the kiln is no longer firing up when plugged into the controller?
  2. Adjuster

    Late Member

    Dec 26, 2010
    The first thing to look at might be the plug or socket where the controller attaches to the kiln pyrometer, or any lead, cable, or adapter used to join them together.

    Next might be whatever circuits inside the pyrometer actually respond to the controller, such as perhaps opto-couplers or relays.
  3. jeweler

    Thread Starter New Member

    Nov 23, 2011
    Thanks. I'm thinking I might need a new pyrometer, but the repair people didn't seem to think that was the problem. I'm going to try to contact the kiln manufacturer.
  4. crutschow


    Mar 14, 2008
    Have you tried testing the pyrometer?
  5. jeweler

    Thread Starter New Member

    Nov 23, 2011
    The only test I have done is to plug in the kiln, turn it on low and then see if the temperature gauge shows the proper temperature by putting a thermometer inside the kiln. I got the correct reading. What are other ways to test the pyrometer?
  6. thatoneguy

    AAC Fanatic!

    Feb 19, 2009
    How did the control unit fail? Was it after moving, a long session, or anything else unusual between the time that it was working and wasn't?

    Did it stop working while the kiln was running, or during a "cold" period?
    The details like will help narrow down possibilities.

    How old is the kiln and the controller/pyrometer? Do you have a make and model number for the controller?

    Is it plugged directly into a mains outlet, or is there an outlet strip/surge suppressor/etc in the chain as well? I don't think that would cause the symptoms you are seeing, but knowing the full setup also helps.

    One very simple test would be seeing if the PID controller will turn on a light load, such as an incandescent table lamp when the pyrometer is cold or even disconnected?
  7. jeweler

    Thread Starter New Member

    Nov 23, 2011
    I'll have to see if I can find any make and model numbers after turkey day.
    The kiln/controller setup failed during a run in the middle of the night. I had gone into my studio to check on the runabout 3 am and found that the run had halted and there was the word "fail" on the controller display, but no fail code that would give me a clue to the cause. I tried to get it running again but could not get the kiln to heat much past 1250 F. This worked well enough for the wax to burn out of the molds so I could cast the jewelry the next morning.
    Later that day I was fiddling with the settings to see if I could get it working properly again. Then the light on the kiln started to flicker, and soon went out completely. But the kiln would work if I unplugged it from the controller and plugged it directly into the wall socket. This is why I thought the controller was the problem. But it has now been tested with the exact same model/make kiln and works. So the problem is with my kiln. The kiln is a Neycraft, jff2000, at least 10 years old, manufactured by the Ney Dental company which had been bought out by another company. It is still manufactured and parts are still available. I just need to know what part is failing.
    The kiln, which has an internal pyrometer and thermocouple, plugs directly into the cord of the controller (brand name Kilnminder). The pyrometer is attached to the controller via a separate two-wire line. The is no surge protector in the setup (maybe I should add one?).
  8. ifixit

    AAC Fanatic!

    Nov 20, 2008
    • Kiln heater works
    • Controller works
    • Thermocouple has not been confirmed to be working.
    1. Measure the thermocouple probe impedance with an ohm meter. It should read as almost a dead short.
    2. Measure across the controller probe input pins with a volt meter. It should show a voltage of a few volts or so since it apparently works.