Is this wrong with MAX232CPE?

Discussion in 'Embedded Systems and Microcontrollers' started by anhnha, Apr 28, 2012.

  1. anhnha

    Thread Starter Well-Known Member

    Apr 19, 2012
    I used MAX232CPE without any capacitor and power supply is tied.Then I tied the TX of comm port to one pins the the RX of the comm port to another pins of MAX232.Next transmit data to comm port.But i am confusing that I can receive data exactly when TX and RX is tied any pin of MAX232:confused:
    I have tested MAX232 it is good.Would you tell me is this is true?Or there something wrong here?
  2. t06afre

    AAC Fanatic!

    May 11, 2009
    Without any caps at all. I am not sure of the output. But I do not think it would harm the circuit. Anyway use the caps as the shown in the datasheet
  3. anhnha

    Thread Starter Well-Known Member

    Apr 19, 2012
    Yes.I had used caps and tested it but there are serval things make me confused.I can receive even without power supply.Then I remove all caps and power of max232 and tied TX and RX to any pin of max232, say VCC and GND and it can receive data exactly.I wonder if this is true for max232 or not?
  4. debjit625

    Well-Known Member

    Apr 17, 2010
    First of all ,its not much clear what you are trying to a circuit diagram of your circuit.
    May be you meant this...

    It can happen, normally in many ICs ,their are internal clamping diodes on many pins. When you put signal on these pins the power is taken from the signal and power the IC because of the clamping diodes, it only happens with ICs which needs very small amount of power to operate. Once it happened with me too ,I was commutating with parallel port using a mcu ,and I dont even needed to power the mcu i.e.. apply power to Vdd and Vss pin as the power was available from the clamp diode of the pins which were connected to parallel port.

    RS232 chip works on two principal 1)Voltage doubler and 2) Voltage inverter ,both needs capacitors to convert +5VDC to +10VDC and -10VDC ,if you don't use capacitors you can't convert +5VDC to +/-10VDC,as a result you will never be able to transmit any data and I guess you are not able to.

    On the other hand about receiving data may be clamping diodes are doing the magic to step it down but I am not sure, you can post a circuit how you connected the stuff.

    But never do this ,as the clamping diode may get damaged and then your device like mcu may get destroyed because of high voltage.

    Good Luck
  5. anhnha

    Thread Starter Well-Known Member

    Apr 19, 2012
    Thanks for your help.
    I have just attachment my circuit.
    One circuit is the circuit I had used to test rs232-rs485.But I run into a strange problem is that I can receive data without power for circuit.Then in order to debug the circuit I removed all components and I found I amazing things:
    As you can see in the max232_test file that is attached.When i tied TX and RX to 2 pins of max232.The 2 pins can be almost any pin of max232.Then i program to send and received data with the com port.I found that I can receive data exactly.Would you help me confirm that is wrong chip or not?I had checked all paramenter and tested max232 and it is good.
  6. anhnha

    Thread Starter Well-Known Member

    Apr 19, 2012
    Thanks for all help.
    I had debug my circuit step by step and there are several things make me confuse.

    At first I had used the circuit of convert file[attached in this] to transmit data.With TX is tied to R1in of U5 and RX is tied to T1out of U6.Then i used the code to transmit and received to/from com port.Then I am supprising that I can receive exactly data without power supply.
    In order to debug the circuit I checked all components.First, all components in
    the circuit is removed except max232.
    I put max232 into breadboard without any capacitors and power is used.After there is a strange problem that I can not understand and i think this is my problem.
    The strange is that when I tied TX to one pin and RX to another pin of max232 and both 2 pins is can be any pin of max232, then if i run program to transmit and receive data to/from com port, the data in received exactly what to be sent.
    I seem that all max232 pins is connected to each other result in TX and RX pins is connected to each other.
    At fist thought, I think the Max232 is blown but when I checked it under the guide below, all results is relative right.
    This is the guide to test max232:
    "Power up the MAX232 and check voltage across supply pins to insure correct voltage input.
    The following two tests check each "TTL in - RS232 out" converter.
    Put 0 volts into pins 10 and 11, then check pins 7 and 14. Should have about 10 volts output on each.
    Put 5 volts into pins 10 and 11, then check pins 7 and 14 again. Should have about -10 volts output on each.
    If that succeeded, then check each "RS232 in - TTL out" converter. Connect pin 7 to pin8. Connect pin 13 to pin 14. This will be a "loopback test".

    Put 0 volts into pins 10 and 11, then check pins 9 and 12. Should have about .6 volts output.
    Put 5 volts into pins 10 and 11, then check pins 9 and 12 again. Should have about 4.5 volts output."
    There it is make me confuse that in the circuit when i tied TX in one pins
    it is appearded that all pins is connected each other and I received data exactlly without power supply.