I don’t see Ports (COM & LPT) in the Device Manager

Thread Starter

steven334

Joined Aug 9, 2011
37


I want to install the drivers for my new Arduino Uno.
I am following the instructions bellow, but I don’t see Ports (COM & LPT) in the Device Manager . ( I am running on windows 7 ) .
Thanks for reading
Steven

Instructionhs from
http://arduino.cc/en/Guide/Windows
4 | Install the drivers
Installing drivers for the Arduino Uno with Windows7, Vista, or XP:

  • Plug in your board and wait for Windows to begin it's driver installation process. After a few moments, the process will fail, despite its best efforts
  • Click on the Start Menu, and open up the Control Panel.
  • While in the Control Panel, navigate to System and Security. Next, click on System. Once the System window is up, open the Device Manager.
  • Look under Ports (COM & LPT). You should see an open port named "Arduino UNO (COMxx)"
 

Attachments

spinnaker

Joined Oct 29, 2009
7,837
I want to install the drivers for my new Arduino Uno.
I am following the instructions bellow, but I don’t see Ports (COM & LPT) in the Device Manager . ( I am running on windows 7 ) .
Thanks for reading
Steven

Instructionhs from
http://arduino.cc/en/Guide/Windows
4 | Install the drivers
Installing drivers for the Arduino Uno with Windows7, Vista, or XP:

  • Plug in your board and wait for Windows to begin it's driver installation process. After a few moments, the process will fail, despite its best efforts
  • Click on the Start Menu, and open up the Control Panel.
  • While in the Control Panel, navigate to System and Security. Next, click on System. Once the System window is up, open the Device Manager.
  • Look under Ports (COM & LPT). You should see an open port named "Arduino UNO (COMxx)"
You know you can just press the Print Screen key on your keyboard and paste it to Paint? There is no need to snap a hard to view photo of your screen.


Obviously you don't have any serial or parallel ports on your system.

Do you have the corresponding connectors?


There is an Unknown device. Could that be a USB serial interface cable? If so, you have the drivers installed?
 

Thread Starter

steven334

Joined Aug 9, 2011
37
Do you have the corresponding connectors?

Well i have my printer. So i unplugged the cable going into my printer and plugged it into my arduino. ( I hope that was OK).

There is an Unknown device. Could that be a USB serial interface cable? If so, you have the drivers installed?


I don't know what the unknown device is. I dont think i installed the drivers. I just downloaded the Arduino environment.
 

t06afre

Joined May 11, 2009
5,934
You could try to manually add the hardware driver. Just google this phrase -> manually add hardware windows 7. Close to the USB port on your board. It should SMD chip with more than 6 pins. Can you see the brand of this chip. Is it Atmel or FTDI? If it is Atmel the driver inf file should be located in the located in the "Drivers" folder of the Arduino Software download (not the "FTDI USB Drivers" sub-directory).
 

spinnaker

Joined Oct 29, 2009
7,837
Do you have the corresponding connectors?

Well i have my printer. So i unplugged the cable going into my printer and plugged it into my arduino. ( I hope that was OK).

There is an Unknown device. Could that be a USB serial interface cable? If so, you have the drivers installed?


I don't know what the unknown device is. I dont think i installed the drivers. I just downloaded the Arduino environment.

You still have a printer that has a parallel port? How old is it?
 
Top