High or Low Voltage being monitor on Drain (TPIC6B595D)

Thread Starter

WapitiTCP

Joined Apr 12, 2017
9
Will 24V and 5V cause a problem on LED0 D1, when TPIC6B595D Drain7 (O5005A8) at 5HZ 50% on and off?

There is another input to monitor the voltage level on O5005A8 as WatchDog Monitor, which is monitoring 5HZ signal.

For some reason, the Watchdog think it fails at 5HZ if on or off time of period longer than 1.5s

Please advise me what problem could be with this circuit with 24V and 5V on LED0? when Drain is open.

Thanks a lot for any ideas.
170NX-TB.jpg
 

ericgibbs

Joined Jan 29, 2010
15,743
hi TCP,
Welcome to AAC.
What is the specified reverse voltage breakdown of LED0.?
What is the failure mode you observe.?
E
 

Thread Starter

WapitiTCP

Joined Apr 12, 2017
9
hi TCP,
Welcome to AAC.
What is the specified reverse voltage breakdown of LED0.?
What is the failure mode you observe.?
E
Hi Eric,

The reverse voltage breakdown is 5V
The conflict monitor is watching this watchdog signal at 5hz, it reports a fail after running a couple of days in the field.
Do you think this could cause watchdog fail?

Thanks,

170NX-TB-1.jpg
 

ericgibbs

Joined Jan 29, 2010
15,743
hi TCP,
You could try connecting a regular diode in series with LED0, with a high value resistor across LED0, say a 100K.
E
 

Thread Starter

WapitiTCP

Joined Apr 12, 2017
9
hi TCP,
You could try connecting a regular diode in series with LED0, with a high value resistor across LED0, say a 100K.
E
Hi Eric,

Since I have a jumper for LED0 to disconnect or connect to Drain O5008A8, I tried it with or without, but seems no difference. also compared to a good different controller.

Plz check the attached pictures: 1st one is disconnect LED0 to Drain, the 2nd is connected to Drain, the 3rd is a old but legacy controller has been running for more than 20 years.

Disconnected to LED0.JPG
Disconnected to LED0

Connect to LED0.JPG
Connected to LED0

GoodOne.JPG
A Good Controller(different device) passed OK for 30 years
 

ericgibbs

Joined Jan 29, 2010
15,743
hi TCP,
That Opto emitter is being run on a very low current, if the 5k1 is being pulled to 0v.
Say 23v/5100 = 4.5mA, I guess you know that opto's degrade with time.?
E

Can you check pin #5 of the opto, bottom of R270 for any change in pulse width.
 

Thread Starter

WapitiTCP

Joined Apr 12, 2017
9
hi TCP,
That Opto emitter is being run on a very low current, if the 5k1 is being pulled to 0v.
Say 23v/5100 = 4.5mA, I guess you know that opto's degrade with time.?
E

Can you check pin #5 of the opto, bottom of R270 for any change in pulse width.
I will check Pin5 of the opto. 4.5mA is kind of low current, but it has been designed like that for years.

23 x 1 /(1K+47K) = 0.48V on R276(1k) when Drain is close. 0.48 < 6V, on U270 LM324 Pin #10.
 

ericgibbs

Joined Jan 29, 2010
15,743
hi,
I am building a LTS simulation of this circuit, a little difficult creating the waveforms.
Hope to have something to post tomorrow.
E

On the scope images you posted, what is the Y scale factor per division.?

Exactly which point on the circuit is the scope probe connected.?
 

Attachments

Last edited:

Thread Starter

WapitiTCP

Joined Apr 12, 2017
9
hi,
I am building a LTS simulation of this circuit, a little difficult creating the waveforms.
Hope to have something to post tomorrow.
E

On the scope images you posted, what is the Y scale factor per division.?
Hi Eric,

Just ignore 24V with 10K circuit. Look the picture I highlight. Note: O5005A8 is the same net of WATCHDOG.

I checked Pin 2 on 4051 which is the same as Pin 5 of Opto, but I could not see 5hz signal there.

Thanks a lot for your help.
 

Thread Starter

WapitiTCP

Joined Apr 12, 2017
9
hi,
Please scope check LM324 pin #8, also #9 and #10.
Lets know what you measure.
E
Hi Eric,

I could not find out LM324 in the newer version of Watchdog Monitoring circuit. Do you think 19V reversely on LED0 will cause it down to 5V compared to 6V REF on LM324?

Please advise me, Thanks a lot.
 
Top