help with smd eagle brd layout

Discussion in 'The Projects Forum' started by bisctboy, Jul 2, 2009.

  1. bisctboy

    Thread Starter Member

    Nov 3, 2008
    I have 3 smd ic's in my schematic along with 12 other smd componets. Eagle can't seem to autoroute them completely and ALWAYS comes back with 61.5% complete no matter what I do to the arrangement. The unrouted wires are ALWAYS connected to my 3 smd ic's. Does anyone a recommendation for my DRC settings that would fix it? I have attached the brd file as well.
  2. StayatHomeElectronics

    AAC Fanatic!

    Sep 25, 2008
    Why don't you try to manually route the last few wires?

    You may or may not be able to route all of the lines on a single layer without jumpers connecting a few lines. You can add the jumpers as components to the schematic on the line/lines that remain unconnected.
  3. R!f@@

    AAC Fanatic!

    Apr 2, 2009
    I guess you have to use double layer or more layers in your pcb then

  4. jpanhalt


    Jan 18, 2008
    That is odd behavior. Some of the missing routes are trivial. I could ripup other of the routed airwires, and they re-routed correctly. When I manually routed the non-routing wires, the routed traces acted normally. I don't think it is a DRC issue, because it is the same pins affected on both NCP1402's and there is no crowding issue.

    That leaves me to suspect a problem with your Device definition in My_Parts. Are the unrouted pins defined ? In the Device definition, are they connected to something in Symbol and Package definitions?

  5. jpanhalt


    Jan 18, 2008
    I have been playing with this board for the past 45 minutes, even made a new device, and used the new device to replace one of the NCP1402's. I can route manually, but the autorouter still misses it.

    The simplest solution is probably just to use the autorouter to help get your parts placement how you want it, then manually route those few nets that don't autoroute. That is not intellectually very satisfying, but at least you will have a usable board.

  6. THE_RB

    AAC Fanatic!

    Feb 11, 2008
    Have you tried setting the autorouter grid to a finer setting? Those SMD pads are probably spaced wrong for a coarse grid and the autorouter is forced to miss them.