Discussion in 'Off-Topic' started by integerspin, Nov 18, 2013.

  1. integerspin

    Thread Starter New Member

    Nov 18, 2013
    I have just registered as I am often trying to mend stuff,
    I find a slap and a poke with my finger does the job, or the thing
    gets assigned to the bin. I am hoping for some advice on electronics problems.
    I have just successfully repaired the non-working ultrasonic cleaner I
    bought on ebay and feel well chuffed[OK slightly amazed as well].
    I now have to mend the Newall digital readout for my milling machine.
  2. MaxHeadRoom


    Jul 18, 2013
    I couldn't find that method in the manual? :(
    What is wrong with the DRO?
    They are a fairly high end make.
  3. integerspin

    Thread Starter New Member

    Nov 18, 2013
    The DRO [DROs] I have are pretty old. One has 1989 on the main board the
    other has 1983. One failed in 2003, it showed random bit's on the display[vfd],
    but if left on a few days it settled down; it was left on all the time until
    2006 when it failed again, but I have forgotten what failed. I asked about
    fixing it on an engineering forum and someone offered me a working one
    for 20 quid; so I bought it and have asked if anyone has one for sale now,
    but it's been a week and I haven't been offered another.
    Last year, a month before I had to have the DRO, it failed. It read SF[signal failure]
    on both axis and the error wouldn't clear. I assumed as the error just
    appeared on both axis it was unlikely to be a scale problem. I swapped
    boards around from the first DRO and got it working, I think I swapped the
    'not an axis' board[not sure what to call it] and it worked.
    I need the DRO in a couple of weeks. A month or so ago I switched it off
    for some reason, I switched it back on last week and there was no display
    at all, I tried swapping a few boards again but no luck, poking it with my
    finger wasn't to successful either. The error is deeper than no display as
    there is a pair of LEDs to show if it's in metric or imperial and pressing the
    mode button doesn't change these, which it should.
    I can't see any thing wrong with the capacitors, but have been advised in
    the past to replace all electrolytics on old kit and all my kit is old, so I will
    replace those and I could see the leads on a microprocessors looked a bit
    green, so I pulled it from it's socket and the 40 pin dip socket needs
    replacing or cleaning and a few terminals replacing.

    I have no idea how to ask about any of this really, "help my circuit doesn't work"
    isn't going to get me very far. I suppose I should move this and start with
    something like "what do I need to ask?"

    Newall scales are pretty groovy. But there is only one alternative readout unit which
    seems to work with the scales, it is cheaper than a Newall readout, but still more than the
    chinese readouts for optical scales.
    Last edited: Nov 18, 2013