HAL.dll Error RAID 1 System

Discussion in 'Computing and Networks' started by jpanhalt, May 24, 2009.

  1. jpanhalt

    Thread Starter Expert

    Jan 18, 2008
    I just finished getting my "clean" PC up and functional after adding a major crash. I am not a member of any PC related forums, so I thought I would post that experience here. That way, anyone who searches on the subject will find this post. Over the last two days, I did a lot of those searches myself.


    System is a Asus P5QC mobo, P45 chipset, Intel Core2 Quad 9400 CPU, dual SATA HDD in Raid 1 (ICH10R), and Nvidia(EVGA) GTS250 video card. System was working well in RAID. Installed a legacy Quadro FX3700 video card hoping to get full compatibility with SolidWorks. During boot, I got an error message about the BIOS having the wrong date. I corrected the date and didn't check other important settings, like the storage configuration and boot sequence. That was a big mistake, in retrospect. The storage configuration had been changed to IDE and the RAID array was broken. It completed boot, and I started getting funny messages about needing to re-register certain software. In the course of testing SolidWorks, I checked Windows explorer and noticed drives G and H had appeared, which previously had been the mirrored set for drives C and D of the RAID, based on their sizes.

    I edited BIOS back to RAID, but then the PC would not boot and gave the error:

    "<windows root>\system32\hal.dll missing or corrupt"

    Most people at this point will have found the Microsoft knowledge base articles: kb945380 and kb307654. The latter tells how to use Recovery Console, and the former tells how to rebuild or resynchronize a RAID set, supposedly. Some people may try to copy the new files (presumably hal.dll and NToskrnl.exe) onto each drive. I am not that brave.

    The problem is that kb307654 will not work with RAID. With luck, you can boot from the CD with storage configured for RAID, but you immediately get a blue screen with the error ***Stop:0x0000007B.


    Two days and many hours later, here's what worked. It appeared that most of the changes after breaking the mirror had been done to Drive C, which I could physically identify (call it #1 drive and #1 cable). I took the SATA cable from that drive and plugged it into the other drive (#2 drive and #2 cable). I left the original #1 drive and #2 cable unplugged. BIOS was set to RAID. System then booted normally -- not from the CD -- and gave errors about a degraded or missing RAID. At that point I was able to install Intel's Matrix Storage Console onto drive #2. Shut down the PC, reattached the #1 drive to the original cable #2. Rebooted and followed Intel Matrix Storage Console directions to rebuild the "new" drive now attached to cable #2. The rebuild is slow and took about 2 hours for 500 GB drives (only 420 GB was formatted). On the first cold reboot, Windows did CHKDSK on both drives.

    Lessons Learned:

    1) When you see a BIOS error on installing a device, always check the other settings, not just the one mentioned in the error message.

    2) Install Intel Matrix Manager appropriate for your RAID chipset, while your system is working. It is a small program, and you will never notice it is there, except it will give a message that you are protected when you boot.

    3) Microsoft KB's are helpful, but apparently don't work well with RAID'ed systems.

    4) This reaffirms my opinion that restore and repair (i.e., press "r") don't work that well. When they work, it's great, but after the first try, do something else. Unfortunately, a full install would have formatted the drive, and I would have had a lot of rebuilding to do afterwards. Matrix Manager avoided having to do that.

    5) During all of the failed attempts, Drive#1 had a file added to it by Windows, "pagefile.sys" that got very large (>2GB). Now that file is copied to both drives. I should have tried to delete it before the rebuild.


    Does anyone know about the pagefile.sys file? Can it be deleted? Why so darn big?

    I hope this experience will help someone else someday.

  2. bertus


    Apr 5, 2008
  3. jpanhalt

    Thread Starter Expert

    Jan 18, 2008
    Thanks. Now that I know how it works and that it can be configured, I will leave it alone for the present.

  4. studiot

    AAC Fanatic!

    Nov 9, 2007

    Why did the BIOS loose the date - was the battery low?
    I would certainly recommend checking it - in situ so you don't bust your RAID again.
    Was the OS XP or Vista?
    How do you find Solidworks as a matter of interest?

    and thank you for posting your experiences.
  5. jpanhalt

    Thread Starter Expert

    Jan 18, 2008
    My thought too. I pulled the cord for about 5 minutes and boot went fine afterwards. The mobo is new and maybe a little jiggle on the battery caused the loss. I will test it more rigorously, as we are about to enter thunderstorm season and can have outages of 30 minutes or more.

    The OS is XP Pro sp3.

    I am very new at Solidworks. Those who know it, seem to like it. My earlier 3D program (Ashlar-Vellum, Cobalt) used a plain background, and it was easy to lose or invert orientation. The shading and lighting on Solidworks makes that part a non-issue. On the other hand, Cobalt was more intuitive and the tool icons stayed put. That is, the toolbars were not context driven. SW 2008 is much improved over 2007 IMNO in that respect. The icons don't seem to jump around as much.

    When I am just sketching, I still use an old 2D program from Ashlar-Vellum called Graphite. It is so intuitive, I rarely used paper after the first few months. Old habits are hard to break, but for shear speed in making a 2D pattern for something, I can't see SW ever being that easy.