Full Wave Rectifier circuit not working?

Discussion in 'General Electronics Chat' started by Imdsm, Mar 29, 2011.

  1. Imdsm

    Thread Starter Member

    Feb 11, 2011
    I was playing in Multisim 11 and can't seem to get a full wave rectifier to work.. I'm just wondering if this is a problem with the circuit or if the software is, for some reason, decided to bug on me?

    I know the ground is in a different place in this picture but that was to keep it out of the way, even putting it in the same place as the circuit diagram yields the same results.

    It looks as though something explodes and then the voltage goes wacky..

    Anyway, any help on explaining what's going on here would be useful to my education and to my headache. :D thank you!


    (bigger image here: http://i54.tinypic.com/27ycqpf.png)
  2. SgtWookie


    Jul 17, 2007
    Try changing the 1N4148 diodes to something more robust, such as 1N4004's, etc.

    You should leave the ground where it was originally. Moving the ground changes the circuit.
  3. Imdsm

    Thread Starter Member

    Feb 11, 2011
    Just tried it with 1N4004's but still the same thing happens, I only used 1N4148's as I have one sat in front of me at the moment and couldn't find any documentation on what diodes should be used. Wasn't aware shifting the ground would make a difference, it's back in it's proper place now.

    Must be a multisim bug I suppose. Thanks Wookie!
  4. mbohuntr

    Active Member

    Apr 6, 2009
    Try moving the ground to the negative side of the Cap like Wookie said, , and check your scope to make sure it is set for DC. I use Multisim v10, and set up like this, it works fine.
  5. Imdsm

    Thread Starter Member

    Feb 11, 2011
    Ah crap, yep, was set to AC instead of DC, my bad. Thanks a lot mbohuntr, and wookie, time for me to read up on the effects of grounding as well I think!

    Cheers all