ethernet: resource conflict, IBM ThinkCentre

Discussion in 'Computing and Networks' started by eblc1388, Dec 22, 2010.

  1. eblc1388

    Thread Starter AAC Fanatic!

    Nov 28, 2008
    I'm puzzled by the behavior of the integrated network port on an IBM ThinkCentre S50 Motherboard.

    I got this PC from people selling them as an office equipment clearance.

    When I powered it ON, it boots straight into WindowXp without problem or any error message. However, there is no network available. No network adapter appears in PC hardware manager list also. I then power down and enter BIOS screen, noting that the on-board ethernet controller option has been disabled. So I thought it would be a piece of cake just to turn it back on and save back the new setting to CMOS. I'm home and dry.

    On power up again, POST immediately reports an error message 1806 on PCI/PnP resources conflict. It clearly states that it is caused by the motherboard ethernet controller. Thinking that it could be a driver problem I then proceed to boot into XP and note the yellow exclamation mark on the network adaptor saying software for the device has not been installed. Fine I go ahead and installed the correct driver. Installation completed successfully and OS requested a system reset.

    After a reboot, still the same POST resource conflict error message and inside device manager the yellow exclamation mark on the network adapter is still showing. However, this time the problem is that Window cannot start the device(probably because of the hardware resource conflict).

    I then went back into BIOS and disable the ethernet controller and verified again the resource conflict message has disappeared. I powered down the PC again and installed a separate PCI network card. To my surprise, the POST immediately reports that the new PCI network card I have just inserted also caused resource conflict.

    Finally inside BIOS I disable the sound card and all the COM and parallel port to free up some resources but the error remains. I have fully discharged the CMOS, loaded the system defaults and even upgraded the BIOS versions to the latest version to no avail.

    How can integrated peripherals on a motherboard cause resource conflicts among themselves? Obviously one can't move them into different slots to resolve the problem like cards on PCI slots.

    What could be the problem? What other options do I have?
  2. R!f@@

    AAC Fanatic!

    Apr 2, 2009
    Hey , where have you been.

    By the way...Is the mother board having any bulging caps?
  3. eblc1388

    Thread Starter AAC Fanatic!

    Nov 28, 2008
    No luck in finding bulging caps. Most of the components are surface mounted and appear intact.
  4. R!f@@

    AAC Fanatic!

    Apr 2, 2009
    The Electrolytes sometimes gives lot of funny problems.

    If you had disable the lan then I do not seem to understand any reason for a resource conflict.
    Try Disabling every onboard hard ware. If you are using onboard VGA, try with a card.
  5. jpanhalt


    Jan 18, 2008
    I went ahead and searched on your problem. I am sure you did too. My search terms were: thinkcenter ethernet conflict. This thread was the first hit. There were several incidences of similar problems and no definitive answers. Here are some relevant suggested solutions. Unfortunately, I saw no instance in which someone said the remedy worked.

    I didn't know a version existed for refurbished PC's. Not sure I believe it either. But just in case it is true, maybe you have a downgraded version of Windows. Can you clean and install a good copy? (dread)

    And last comment:
    The final diagnosis in the above case was bad motherboard.

    Sorry, I can't help more. This is out of my league.

  6. eblc1388

    Thread Starter AAC Fanatic!

    Nov 28, 2008
    Yes, I did that too, extensively. Thanks for putting in your effort for this strange aspect on the motherboard.

    I have also downloaded the IBM hardware Diagnostic Utility (PC Doctor) and have every test completed successfully except a device which cannot be started on the PCI bus.

    The device is the Intel Pro/1000 MT Desktop Connection ethernet controller and all the drivers I have tried so far just doesn't work. May be the PC is configured to have codes downloaded on startup(network booting)for it to work, I don't know.

    I still suspect the controller requires a proper driver to work and without one would just refuse to share an IRQ with other PCI devices, causing the resource conflict problem.

    Worse come to worst I would just buy an USB-Lan and be done with it.

    I'm very happy with all the other aspects of that PC otherwise.

    Happy Christmas to you and other forum members.

    P.S. I just come across something that I might try to see if it can solve the above problem. It is something called the Preboot Utility. I have no idea what to do with it and whether it would apply to an onboard controller so would need to research further about how to proceed.

    Last edited: Dec 24, 2010
  7. eblc1388

    Thread Starter AAC Fanatic!

    Nov 28, 2008
    There is some new information coming up.

    I don't have an external USB drive to verify the "solution" but I don't understand how it works.

    Where did that type of enumeration information being stored? I have already cleared the CMOS, loaded the system default settings and reflashed the BIOS to no avail.

    The POST check detects the conflict on boot before even loading the OS so that information must be stored somewhere on the motherboard.

    Is there some parts/sections of the CMOS that will never get cleared even by user?
  8. R!f@@

    AAC Fanatic!

    Apr 2, 2009
    I too had a the same issue with a ThinkCenter Mobo..

    POST seem to show time after time. Quite regular I must say
  9. eblc1388

    Thread Starter AAC Fanatic!

    Nov 28, 2008
    I have disabled the internal ethernet controller in BIOS and plugged a PCI network card into one of the two empty PCI slots of the PC.

    Every time the POST complaints of resource conflict albeit with different Device number.
    Code ( (Unknown Language)):
    2. error 1806: Resource conflict
    4. Internal ethernet controller:   Bus:03, Device:0B, Function:00
    6. Then after disabled the internal ethernet controller in BIOS:
    8. External PCI network card:     Bus:03, Device:0A, Function:00
    9. Same PCI card in another slot: Bus:03, Device:09, Function:00
    11. All correctly identified by the BIOS as Network controller
    13. Same result with yet another network card. Same result even after all
    14. Interrupts which I can disabled via the BIOS like IDE/USB/Floppy/ports
    That's it. I won't spend more time looking for a solution but instead go for an USB-Lan adaptor or the USB wireless network card.

    To the unlucky guy who have located this posting suffering the same problem, take heart, you are not alone. :)
  10. rizwan_waris

    New Member

    Mar 16, 2012
    Just Try to Replace the CPU Battery.
  11. K7GUH


    Jan 28, 2011
    Old Latin proverb: caveat emptor. The problems you have experienced may explain why the item was for sale, especially if it was for sale "cheap".
  12. BillO

    Distinguished Member

    Nov 24, 2008
    I dunno,

    I bought one of these from Tiger Direct about a year ago and it's been an absolute charm.

    This thread is old, but in case something like this happens to someone else, a resource conflict of this type is caused when two I/O devices are a) using the same interrupts and have not been properly configured for interrupt sharing; b) are using the same I/O port addresses; c) are using the same buffer ram addresses; d) any combination of these.