Error Programming PIC18F452 - No device detected

Thread Starter

facpi93

Joined Jul 26, 2021
3
Hi guys!,
I'm working in a firmware with PIC18F452 microcontroller, after compiling and programming the chip, the microcontroller seems not to work anymore. The circuit does not init, and I am not able to reprogram the chip anymore. Im using Pickit2, having a no "device detected error".
I've checked everything and I'm nearly sure that is not a hardware issue. ( Signals PGM/PGC okay, supply voltage levels okay, VPP voltage level okay (using a 10k pull-up, manual device selection, disabling fast programming, and all the software setting variants )
¿Could I have damaged the chip memory o something like that? In that case, ¿is there a method or solution to recover the chip?

Thanks!!
 

Attachments

click_here

Joined Sep 22, 2020
446
When I get that error with the PICKit3 it usually means that I forgot to power up the circuit.

You can also try closing the IDE and reopening it, or resetting your computer, as I have found sometimes updates seems to interfere.
 

Thread Starter

facpi93

Joined Jul 26, 2021
3
When I get that error with the PICKit3 it usually means that I forgot to power up the circuit.

You can also try closing the IDE and reopening it, or resetting your computer, as I have found sometimes updates seems to interfere.
Hi!, I've tried all those things. Unfortunately, it seems to be an internal chip problem..

Thanks!
 

Thread Starter

facpi93

Joined Jul 26, 2021
3
hi f93,
Have you checked these settings.?
E
Hi ericgibbs!, I've checked all those settings, and I tested power by both Pickit2 VDD and external power supply.
Yesterday, I removed chip from PCB and wired it on a protoboard, to discard some peripheal problem in the board with PIC. The result has been similar. Also, in the same protoboard I wired a PIC18F2550 to Pickit2, having no problem to detect and program it.

I´ve changed the external crystal oscillator too.

It seems to be an internal problem of the chip, related to memory or some voltage surge. I've programmed it for no more than 20 times.

¿Is it posible to reload firmware from anoher method or bootloader?

I suspect the chip kept in a unbootable state after a bad programming.

Thanks!
 
Top