DMM diode testing, weird readings?

Thread Starter

prometei

Joined Apr 13, 2008
74
hi,

I'm getting weird readings on one of my DMM's when testing diodes.

E.g. I'm using USB power, the DMM (in Vdc measurment mode) read 5V, I insert a 1N4007 between the positive probe and positive pin of USB, and instead of getting a lower reading because of the diode's voltage drop I get a higher one, 6V. When I flip the diode, i.e. insert it reverse biased I still get a reading and it's -1.2V.

I've tried another DMM with the same setup and get the expected results, i.e. voltage drop when the diode is forward biased and 0 volts when reversed.

Is the first multi-meter busted? Any ideas?
 

MaxHeadRoom

Joined Jul 18, 2013
23,932
For one your meter is not providing a sufficient current path to test it that way.
Are you using any kind of load in series with the diode?
Max.
 

#12

Joined Nov 30, 2010
18,223
When 2 meters that are supposed to do the same thing come up with different answers, at least one of them is wrong.
The idea that you can get a negative voltage out of a positive supply would seem to indicate that an oscillation is happening, the oscillation is being rectified by the diode being used, and the oscillation is peculiar to the meter. The high impedance of the DC volt meter could make this difficult to trace, even with an oscilloscope. I suggest you place a resistor in parallel with the meter leads to quench the oscillation. I think 1000 ohms would be about right because the USB port can provide 100X that much current.

I am assuming the USB port always provides significant current, but I have heard about devices that negotiate with the computer for more current. Therefore, I might be wrong.
 

Thread Starter

prometei

Joined Apr 13, 2008
74
Why are you using power from a USB port to test diodes on a DMM?
Oh, I wanted to compare the voltage drop reading in diode test mode with the voltage (difference from voltage supply) measured in the voltage mode.
-----
Anywho,
I've reconnected the whole setup again (alligator clips, probes to DMM) and it works, must've been a faulty connection or something.

Just as an experiment I tried a different setup with a voltage divider, 100K + 1K resistors, giving out 50mV. At this low voltage the mili-volt readings of the two DMM's differed.

Powerfix DMM:
- forward biased 1n4007: 525mV
- reverse biased 1n4007: -500mV

Elro m-940 DMM:
- forward biased 1n4007: 6mV
- reverse biased 1n4077: -1, -0.5mV

DMM milivolt voltage divider.jpg
 

AlbertHall

Joined Jun 4, 2014
11,609
Try measuring the voltage without the diode, with both DMMs on AC volts.
I suspect there is some AC there possibly because the ground is screwy, or the USB is annoyed because you're drawing next to zero current.
 

Thread Starter

prometei

Joined Apr 13, 2008
74
Looks to me like my DMM's are not good at measuring very small voltages so I tried measuring the current.

Without the diodes (see picture above) both DMM's measure a 25uA current, with the diodes, forward or reversed biased, zero current.
 
Top