DEX protocol / vending machine audit data

Discussion in 'Computing and Networks' started by davidc, Aug 2, 2012.

  1. davidc

    Thread Starter Member

    Jul 2, 2009
    Hi folks. Just wondering ...

    Does anyone here have experience with retrieving audit data from vending machines via the DEX protocol? We've run into a few issues trying to do this at work.

    As far as I can discern the methods we are using are valid. We have tried using both third-party software and our own to retrieve audit data from two different machines. One of the machines works ok (most of the time - long story); the other times out at the end of the transfer - sending empty blocks of data repeatedly - and never reaching the end of the audit.

    As far as I can discern there is no provision in the specifications for the way the board is behaving, and we think it is a problem with the board. Nonetheless, if anyone here has worked in this area and encountered similar issues I would be interested in hearing from them.

    (I think it's a problem with the board, but it would be great just to get reassurance that I'm not overlooking anything.)

  2. BillO

    Distinguished Member

    Nov 24, 2008
    I'm not a vending machine guru, but I have a buddy that owns a few dozen of them. He tells me that you more than likely need to replace the control boards. Not that he is a MCU whiz, but he says that that is what he does when things like this happen. Then he sends them in to a guy (who I don't know) that exchanges them and apparently repairs/refurbishes the ones he gets in, so my buddy never really knows what goes wrong with the bad ones.

    I'm pretty sure this will not help much, but it's the best I could do.:confused:
  3. davidc

    Thread Starter Member

    Jul 2, 2009
    BillO: my sincere apologies for not responding till now - I forgot about this thread and only thought to check it again in the last day or two.

    In the end I contacted the original manufacturer of the board, told them the errors we were getting, and they told me the same thing - the hardware is faulty. (I had tried to contact them previously but they hadn't responded to my initial e-mails).

    Thankfully we had another development board available for testing - so it didn't halt progress entirely.

    Thanks for your feedback.