cleaning corroded pcb?

Thread Starter


Joined Nov 18, 2013
I have some circuit boards with some corrosion to some tracks.
I have tried gently wiping them with a scotchbrite, need to be pretty gentle to avoid pulling them off the glass. How do people clean them?
I had to remove th edip socket as all the pins were corroded and a couple had corroded through and were missing bit's, the traces don't look as bad in the picture. The other side of the board is nice and clean.



Joined Nov 24, 2012
If that board has more than two layers (looks like it does) it's a throw away.

To clean it, cut down an acid brush so the bristles are stiff and use a baking soda/water paste. Wash it off with clean water and blow dry with air.


Joined May 11, 2009
Why is it corroded? If some battery has caused this. You may replace the corroded tracks with a wire. Soldered from IC/component pin to pin. The board look like some old two layer board So that may do the fix it. If the corrosion is not to bad. But it is also important to remove everything that caused the the corrosion. Take a look at C2 it looks that it is not good shape


Joined Nov 30, 2010
Same opinion here. You're going to do some scraping and replace some traces with #30 wire. Maybe bigger than #30, but that's what I have in stock, so that's what I use. The other size I have is #22 but that is a bit stiff for this job. Then, there is the idea of stripping a stranded wire and using the strands.


Joined May 4, 2013
You have gotten some good advice. I can only add a few little points...

Do be careful with a stiff wire brush. I prefer the brass brush that DR.killjoy recommended. Even then, be gentle -- you don't want to remove good traces.

After you have the board cleaned up you may still have some trouble soldering to the old pads. If this is the case you should use some liquid _rosin_ flux to cut through the last of the corrosion on the joint.

It is sometimes convenient to solder to the remaining trace rather than a pad. To do this you must first scrape away the solder mask covering the copper. Use a sharp Xacto knife with an angled blade to do this -- take care not to scrap away the trace. A bit of flux may help here as well.

Thread Starter


Joined Nov 18, 2013
It's one of the boards from a Newall digital readout. The readout is basically a tube of steel balls which is attached to the axis of a machine tool, a reader head that moves along the tube and a readout unit powers some coils in reader head
which induce a field in the balls, another set of coils in the reader head and the readout unit then figure out where about's the reader head is. I am pretty much lost without it, well it takes me ages to do everything.

I got the first one in 2003[it's probably a 1983 unit]. As I remember it, it worked but displayed animated nonsense until it
had been on for 24 hours, so it was left on all the time. In 2006 it died, I think it just showed nonsense all the time.
I had the obligatory poke around inside it, I replaced the battery and I thought I replaced the caps[but I am not sure],
clearly that didn't fix it. Someone came to my rescue with another unit for 20 quid. So the not working one got shelved.
My 'new one' worked fine till a few months ago, it showed signal failure and it couldn't be cleared, as it was on both axis I figured it was probably either the 'not an axis board' or the main board, I substituted a few boards[inc this one] and it worked, but had to be left on as before. I need the DRO in a few weeks. For some reason I switched it off last time I
used the milling machine! I switched it back on a few days later and there was no display[VFD] but the unit was powered
on, one of the metric/imperial LEDs came on, but it wasn't just the display out as changing mode[metric/imperial] didn't switch the mode LEDs.

It lives in a cold garage, in the winter the coolant freezes and when it's damp my dehumidfier takes maybe a few gallons of water out in a day but my toys will get dripping wet some nights.

I thought I would start by replacing the electrolytic capacitors.
I wonder if C2 is just the picture is bad, I hadn't noticed anything wrong with it, if you look at X1 it has a green felt tip
spot on it maybe that is what is on the cap.
I was quite pleased to get the dip socket out, I wasn't really getting anywhere with solder braid or a solder sucker, I
don't have a small iron with enough watts for the braid and found the sucker really needed to be around the iron. I
welded a copper mig tip to the copper tip on a pound shop 30W soldering iron and sucked through the tip, it worked a
treat. But I had to use flux[Frys plumbers flux]. I will get some bicarb to neutralise the acid. If I do get it fixed I suppose I should spray the boards something.
Last edited: