Can't use "Paste" function in LTSpice.

Discussion in 'General Electronics Chat' started by tanjk1618, Nov 10, 2010.

  1. tanjk1618

    Thread Starter New Member

    Nov 10, 2010

    I am using LTSpice iV (Version 4.09z). Whenever I copy/duplicate a component the Paste button is still remain grey and I can't even perform the Paste operation by Ctrl-V.

    Is there any hidden settings to enable Component Paste?
  2. Bernold

    New Member

    Jan 5, 2011
    In LTSpice, Copy/Duplicate is a "MODE" and needs to be used just as cut, wire or placing components.

    You can duplicate components or circuits in 3 steps:
    1. Click on duplicate in the Edit menu (or press F6)
    2. Select the area with the components you want to copy in the Schematic
    3. left click on the position where you want to place the components

    That means you can NOT select components first, then copy with Ctrl-C and afterwards paste by Ctrl-C (or in the menu) as you would do in most other programs...
  3. Theagentxero

    New Member

    Aug 26, 2014
    I found a solution to this problem. (I admit, a few years late, but maybe this will help someone who had the same issue I did.)

    If you are able to copy, duplicate, and cut, but are unable to paste...

    Follow This Guide:
    (This Guide Written Based on LTspice 4.21 Installed)

    If you are using Windows 7 (any edition) (32 or 64 bit):
    Make Sure LTspice is closed before these things are changed.

    1) Right click the LTspice icon on your desktop.
    2) Click "Properties" from the context menu.
    3) Click on the "Compatibility" Tab of the window that just opened.
    4) Look for a group box labeled "Privilege Level".
    5) Inside privilege level there should be a check-box that says "Run this program as administrator".
    6) Enable the check-box.
    7) Click the "Apply" Button.
    8) Click the "OK" Button. The Properties window will close itself.

    You can now restart LTspice and you should be able to copy and paste without issue.

    If you'd like to know why LTspice needs to be run under admin privileges, then see the bottom of this post.

    If you are using Windows XP (any edition) (32 or 64 bit):

    1) Locate the LTspice executable in Windows Explorer.
    (It should be at C:\Program Files\LTC\LTspiceIV\scad3.exe)

    2) Press and hold down the SHIFT key while you right-click the program icon, and then click "Run as".
    3) Click "Run the program as the following user", and then type the user name, password, and domain of the administrator account that you want to use.
    4) This should execute LTspice under admin privileges allowing you to copy and paste for that session.

    --- I'm now done with the solutions section, and I'm off on a tangent for those who are inquisitive. ---

    So, why does LTspice need admin permissions to paste.

    In the windows environment the clipboard is defined globally.
    (I.E. - the same text you copied from a word document can be pasted into a text file, or a web-browser, or into anything that accepts text formatted entities. The same is true or images, or files, or anything you can copy.)

    What ever it is that you copy onto the clipboard has to exist in it's physical Ones and Zeros somewhere. (I don't know exactly where, but I can safely assume it is somewhere in the ram or drive of the PC you're working on.)

    As a programming student I know that there are a great many ways to solve the problem of allowing a user to copy internal (program specific) entities from one internal document to another internal document.

    LTspice must somehow include a clipboard procedure that requires admin permission to allow for the temporary storage of the copied circuit for the few moments between the time that you copied the circuit, to the time you pasted the circuit. (I don't know the particulars of the LTspice procedure. But I can tell you that LTspice was attempting to write to a temp file on my drive whenever I duplicated, cut, or copied a circuit. But that Windows would not allow the read/write operation due to the permissions level of the program.)

    When run under standard permissions LTspice does not have the authority necessary to write that temporary file, so the temporary file containing your copied circuit does not exist, and thus... LTspice cannot paste from a file that does not exist.

    We solve this by giving LTspice the permission to act as administrator on your behalf, and it now has access to the read/write functions of it's temporary storage location.

    LTspice can now write to and read from it's circuit storage place, and thus copy and paste now function as designed.
    Last edited: Aug 26, 2014
    absf likes this.
  4. wayneh


    Sep 9, 2010
    Best I can tell, this has no connection to the Mac version. There's no copy function and the only paste function is the placement of components, and that can only be done by clicking, not a keyboard command.
  5. Theagentxero

    New Member

    Aug 26, 2014
    I tried to get an old VMware OSX machine working yesterday.
    I was going to test a suggestion posted elsewhere regarding a way to copy a circuit.
    But, the way that the Virtual Machine was created means it need to be installed with my old processor, so I cannot test this myself.

    The mac functions are not well defined in the user interface, but LTspice for mac appears to have much of the same functionality as the PC version.

    Linear Has A PDF of the Mac Shortcuts....

    Code (Text):
    There is a duplicate function, but no paste function.

    The Suggestion I read, and would like to try is...

    1) open circuit 1 in window, covering half of the workspace.
    2) open circuit 2 in separate window, covering the other half of the workspace.
    3) Select Circuit 1, then press F6.
    4) Drag Duplicate Circuit into Window 2.

    Basically it's a drag and drop approach to copy / paste.

    But like I explained, I really don't have a way to test this because I cannot get my VMware OSX install to work.

    But, feel free to try this out and let me know if it works.
    I'll update my original post here to include a Mac How-To if we can confirm that this works.
  6. SgtWookie


    Jul 17, 2007
    Interesting. I've been running LTSpice with Administrator privileges for a different reason; without it, you can't save schematics in the LTSpice directory - and I'd prefer to not have my schematics in my documents directory.
  7. wayneh


    Sep 9, 2010
    I was stunned to learn that this worked perfectly. (Except that you cannot select a circuit as noted in #3. You have to hit F6 first and then select the circuit. LTspice is all verb-noun instead of the usual noun-verb model of most other apps.)
  8. Theagentxero

    New Member

    Aug 26, 2014
    SUCCESS!!!!! (insert dance smiley here)

    Thank you for testing this, I will update for the suggested changes and put the instructions into the original post. (THIS STEP IS PENDING)

    I am for some reason unable to edit my other posts in this thread to include the new information, i am searching the forums for an answer, but I will post the question of why if I cannot find it.
    Last edited: Sep 5, 2014