Building a RF remote control

Discussion in 'Embedded Systems and Microcontrollers' started by naveen89, Mar 13, 2010.

  1. naveen89

    Thread Starter New Member

    Feb 27, 2010
    10
    0
    Sir,

    I have to make a project on RF Remote Control. I followed the following article http://www.thinklabs.in/resources/?p=12
    In the circuit diagram shown, I noticed two volages, Vcc and Vdd. These are common voltages or separate voltages.

    I have used in total four voltage sources, for Tx, encoder, with common ground and Rx, decoder, with common ground.

    But still I m not able to make it work…

    Please help.
     
  2. retched

    AAC Fanatic!

    Dec 5, 2009
    5,201
    315
    Are you using regulated power?
     
  3. naveen89

    Thread Starter New Member

    Feb 27, 2010
    10
    0
    Sir,

    Thanks for your interest. I have constant DC Sources of 5 volts.

    Regards
     
  4. retched

    AAC Fanatic!

    Dec 5, 2009
    5,201
    315
    What seems to be the problem? Have you double and triple checked your wiring?
    Do you have any test equipment?
     
  5. naveen89

    Thread Starter New Member

    Feb 27, 2010
    10
    0
    Sir,

    I have checked my connections many times. The connectios are according to the diagram given o posted link. The probblem is that voltage across Vcc ad Gnd Pin of Encoder and Decoder is 0.7 Volts. So, I suppose something is wrong there, (or should it be same?). And my circuit does not trasmit anything.

    In any case, I m not sure if my transmitter reciever pair is working. I bought them new and manufacturer ensured me they are working. If there is any way to test them please notify.

    Regards.
     
  6. Markd77

    Senior Member

    Sep 7, 2009
    2,803
    595
    Looks like a power supply problem. Could you post how the power supply is wired please.
    If you are using regulators, are you supplying them enough voltage? A 5V regulator could require 7V or more to work properly, details in the datasheet.
     
  7. naveen89

    Thread Starter New Member

    Feb 27, 2010
    10
    0
    Sir,

    All the four componets (Tx Rx Encoder Decoder) are getting voltages of 5V. Anyways, Sir is there any way I can check my Tx Rx module?

    Please help.
     
Loading...