Amplifier circuit, need more sensitivity or gain?

Thread Starter

Nevalite

Joined Feb 20, 2012
45
Hey everyone,

I have built a small amplifier to run a strain gauge. Here is the circuit:




The problem I am having is that the piece of metal my strain gauge is mounted on does not deform very much and the change in output is very small. The INA131 has a built in gain of 100 and at that setting I can barely notice a difference in voltage, I added a variable resistor over terminal 1 and 8 to change the gain higher. The problem I am seeing is that since I have the 5v regulator in there I can't set the INA131 higher than 5v output.

I turned it up to about 3V output (G=1000ish, the strain gauge outputs about 3.5mV) at rest and added 150lbs of load, this gave me only 0.2V in change. I would like to see 1V of change for every 100lbs, as you can see I am nowhere near the gain setting needed and since I can't go past 5V I am stuck.

What do I do? Is there a way to shift my voltage back down to 0V so I can keep cranking the gain up? I probably need something closer to a gain of 10000.
 

Thread Starter

Nevalite

Joined Feb 20, 2012
45
Still the INA131 of course.

My thoughts:

As long as the op amp is running off the regulated 5v I am not going to be able to output more than 5v regardless of gain. In order to get more juice from the amp I will have to run it directly off the battery. The strain gauge (wheatstone bridge) must stay on the regulator because if the voltage changes the results will be inaccurate. Could I run pins 7 and 4 off the 12v battery and the bridge off the 5v regulator? Then I could output until 12v?

If I can do that, is there a way to then drop it back to the 0-5v range? My data logger (DL1) requires 0-5V input.

Any ideas would be helpful here.

Thanks
 

MrChips

Joined Oct 2, 2009
25,918
I would create a split supply something like this:


I would also replace the 78L05 and 79L05 with low drop-out (LDO) voltage regulators.
I am assuming that the battery will be at least 14V, allowing at least 2V overhead.

Edit: It is possible that you can simplify the design by going to a single supply opamp and hence eliminate the negative side voltage regulator - which would also solve the LDO problem.

Is the load always in the same direction? - i.e. does the signal ever go negative?
 
Last edited:

Thread Starter

Nevalite

Joined Feb 20, 2012
45
I have the INA122 also which is a single supply op amp. The member in question is always in tension so the voltage readings will always be positive.
 

Thread Starter

Nevalite

Joined Feb 20, 2012
45
My question is where does that ground go? When I make this circuit what am I connecting that middle row to? An Actual ground outside the circuit?
 

Thread Starter

Nevalite

Joined Feb 20, 2012
45
In that case do the grounds go to the negative terminal of the battery? Because that's the exact circuit I showed on page 1.
 

MrChips

Joined Oct 2, 2009
25,918
Yes. Connect the negative to GND.
You may have to include some kind of null adjustment if the strain gauges are not already balanced.
 

Thread Starter

Nevalite

Joined Feb 20, 2012
45
This still doesn't fix my original problems about the gain, could I run the amp off 12v, the gauge off 5v, boost the gain and then somehow offset it back down to 0-5v range?
 

MrChips

Joined Oct 2, 2009
25,918
This still doesn't fix my original problems about the gain, could I run the amp off 12v, the gauge off 5v, boost the gain and then somehow offset it back down to 0-5v range?
You could, but it depends on how much accuracy you need.
I would keep the 5V regulator on the gauge and the opamp but work on a null adjustment.
 

MrChips

Joined Oct 2, 2009
25,918
The first thing would be to test the circuit and see if you need the null adjustment.
If the output signal is hitting the GND rail, you can add a positive voltage to pin-5.
If the output signal is already above GND you need to add a negative voltage to pin-5, which brings you back to a split supply circuit.

(I'm calling it quits for the night.)
 
Top