12 Volt PIR to Timer to Lights, 210925

Thread Starter

allenpitts

Joined Feb 26, 2011
153
Hello @sghioto @MisterBill2 @crutschow and the AAC forum,
Have posted on this project at
Post name: Transistor datasheets 210503

Disappointed because it was thought that project was finished and was ready to install
in the closet. But the circuit was left running for half an hour, turning on off from
my movement around the room and I looked over and there was a puff of smoke.

This the latest schematic.
P5L_210925_w_R5_schematic.jpg

Not sure what blew. By the time I could get the power turned off it was hard tell visually which component fried but it seemed like Q2 was warmer than anything else.
Thought I had solved the hyper current issue. First a signal transistor, a BC547 was used at Q2. It got hot and so the BC547 for Q2 was replaced with a AUIRF540Z.
Did not seem to have heat problem with Q2. The data sheet, attached, indicates (I think) that the transistor is good to 36 amps.
So trying to figure out
1. Why the circuit smoked?
2. If the problem is Q2, the AUIRF540Z, why it overheated?

Any insight would be greatly appreciated.

Thanks.

Allen Pitts, Dallas Texas

Oxilam_for_Closet_Light_210805.jpg
 

Attachments

sghioto

Joined Dec 31, 2017
2,417
I don't see anything wrong with the schematic, everything appears to be well within tolerances.
Have you checked the four LED bulbs? Could one of them have shorted out?
 

Irving

Joined Jan 30, 2016
2,311
Assuming no wiring issues its very unlikely to be Q2 unless one of the LEDs went short circuit.

Your schematic shows Q2 as an NPN transistor but now its a MOSFET. The pinout is different. As shown its emitter (1), base (2), collector (3) whereas for the MOSFET the equivalents are Source (3), Gate (1), Drain (2). If it was wired incorrectly it wouldn't work, L1-4 wouldn't come on at all. Since it was working, wecan assume the wiring was good.

Yes, Q2 is good for 36A but that's meaningless in your usage. A more useful figure is that its good for 2W dissipation if not mounted on a heatsink. Your current is 440mA * 4 = 1.76A and the on-resistance of the device is around 20mOhm (0.02Ohm) if its gate pin is at least 10v more positive than the source pin (but less than 20v, yours is around 10 - 11v). So dissipation is approx I^2*R or 1.76 * 1.76 * 0.02 = 0.06W which is << 2W.

I suggest you check your LEDs are all OK and working. If thatsOK, disconnect pin 2 of R4 from the circuit. Connecting it to +12v should turn the LEDs on.
 
Top