XFX 630i (MG-63MI-7109) Fails to power up

Discussion in 'General Electronics Chat' started by Mad Professor, Dec 20, 2009.

  1. Mad Professor

    Thread Starter Active Member

    Apr 15, 2009
    133
    1
    Good Day All.

    I have a XFX 630i (MG-63MI-7109) that fails to power up.

    I am testing this board with good known working PSU, CPU, Memory, ect.

    With eveything connected, when you press the power button eveything powers up for a split second, and the PSU led go's from green to red.

    If I discount the 4pin CPU power connection, and press the power button the system fires up, but there is no post.

    With eveything disconected, I used my Digital Volt Meter to test the 4pin CPU power connection, and it's a dead short.

    There are not poped caps or burnt parts.

    As it is quite hard to test mosfet's in circuit, I desided to remove all 9 of the CPU mosfet's.

    Once I removed all the mosfet's I retested the CPU power connection, and the dead short is no more.

    So one or more of the 9 mosfet's had got dead short.

    I am trying to find the full datasheets for the mosfet's so I can get somthing that is compatible.

    So far this is what I have been able to find out about the mosfet's.

    http://products.niko-sem.com/index_...rod_list&cat=24

    --------------------------

    Part Number: P70N02LDG
    Package: TO-252
    Configuration: Single
    Type: N
    VDS (V): 25V
    VGS (±V): 20V
    VGS(th) max: 3V
    ID (A): 65A
    RDS(on) mO max @ 4.5v: 15
    RDS(on) mO max @ 10v: 8.5
    Ciss typ.(pf): 1200
    Crss typ.(pf): 350
    Qg typ.(nC): 25
    Qgd typ.(nC): 10

    --------------------------

    Part Number: P0903BDG
    Package: TO-252
    Configuration: Single
    Type: N
    VDS (V): 25V
    VGS (±V): 20V
    VGS(th) max: 3V
    ID (A): 50A
    RDS(on) mO max @ 4.5v: 16
    RDS(on) mO max @ 10v: 9.5
    Ciss typ.(pf): 1200
    Crss typ.(pf): 350
    Qg typ.(nC): 25
    Qgd typ.(nC): 10

    --------------------------

    There are also four caps near the mosfet's, and they are Sanyo 1000uf 16v, I am going to replace them as well.

    Can anyone please help and or advice me where in the UK I can buy the same or compatible parts needed to repair this motherboard.

    Thanks for your time.

    Best Regards.
     
  2. bertus

    Administrator

    Apr 5, 2008
    15,648
    2,348
  3. Mad Professor

    Thread Starter Active Member

    Apr 15, 2009
    133
    1
Loading...