what went wrong?

Discussion in 'Homework Help' started by ][ Shocked ][, Nov 30, 2009.

  1. ][ Shocked ][

    Thread Starter Member

    Apr 13, 2009
    22
    0
    hello everybady

    while i was trying to design a BCD adder on Logic Works 4, no results were shown !

    this is what i did

    [​IMG]

    and the display screens don't show what is supposed to be shown


    I hope someone can help me :(

    and thanks for those who cared and red what i wrote
     
  2. SgtWookie

    Expert

    Jul 17, 2007
    22,182
    1,728
    Well, one item that will become an issue is that the '47 is a BCD to 7-segment display, and the '83 is a binary adder. If the output from the right '83 is more than 1001 binary (9 decimal) than you will have a blanked display.

    One way around that might be to use the two '47's and displays to show the results in octal.

    I don't know what you're doing with the AND and OR gates, but it's not quite right, and I don't know why you're using two '83 adders.
     
  3. ][ Shocked ][

    Thread Starter Member

    Apr 13, 2009
    22
    0
  4. SgtWookie

    Expert

    Jul 17, 2007
    22,182
    1,728
    OK, so connect the C1 output to some sort of logic output indicator.

    But keep in mind, that from the left '83 output if the S3 output is high and either S1 or S2 is high, you won't get a display.
     
  5. ][ Shocked ][

    Thread Starter Member

    Apr 13, 2009
    22
    0
  6. StayatHomeElectronics

    Well-Known Member

    Sep 25, 2008
    864
    40
  7. ][ Shocked ][

    Thread Starter Member

    Apr 13, 2009
    22
    0
    I got it

    thx alot :)
     
Loading...