Weller WES51 just died

Discussion in 'General Electronics Chat' started by frenchie29, Jan 8, 2009.

Thread Status:
Not open for further replies.
  1. frenchie29

    Thread Starter Active Member

    Nov 28, 2008
    134
    0
    I was tryin to remove some components on a PCB and tried with a wick and got myself to turn the iron almost all the way up. Now the green light only blinks when it's around 75 (750o) otherwise the tip stay cold. What could of happened??? The unit is not even a month old.
     
  2. SgtWookie

    Expert

    Jul 17, 2007
    22,182
    1,728
    Hard to say.
    Here's a link to the manual if you don't have one:
    ftp://bama.sbc.edu/downloads/weller/wes51/WES51_OI_PL.pdf
    The green light flashes when it's up to temp. If you turn the temp down, the green light will stay off until the tip cools down, then the light will come back on (flashing).
     
  3. frenchie29

    Thread Starter Active Member

    Nov 28, 2008
    134
    0
    soon as I turn it down let's say from 75 to 60 it goes cold
     
  4. frenchie29

    Thread Starter Active Member

    Nov 28, 2008
    134
    0
    I taught it fixed itself I went to put it away so I can return it I pluged it in one last time seemed to work then died out again.
     
  5. frenchie29

    Thread Starter Active Member

    Nov 28, 2008
    134
    0
    I did a reset I think it worked but now I'm confused when I turn it on the light doesn't stop blinking until I hit 60 then soon as I go up a bit the light goes solid

    Here's what it does 50 no light 60 blinking light 65 solid light
     
  6. SgtWookie

    Expert

    Jul 17, 2007
    22,182
    1,728
    If the green light is off, either there is no power or the tip is hotter than the thermostat setting, so the tip is cooling down.

    If the green light is on steady, then the tip is heating up, and hasn't reached the set temp yet.

    If the green light is flashing, it's at the set temperature and is cycling up and down just a few degrees.

    If the red light is on, the temperature is locked in and you have to reset it. See the manual.
     
  7. frenchie29

    Thread Starter Active Member

    Nov 28, 2008
    134
    0
    So is that the way it should be??

    Here's what it does 50 no light 60 blinking light 65 solid light it's increasing

    Shouldn't be
    no light then solid then blinking when it's set? I get the opposite
     
  8. frenchie29

    Thread Starter Active Member

    Nov 28, 2008
    134
    0
    After a few set and reset it's finally back to normal Just wondering if I should still return it? Obviously something went wrong
     
  9. SgtWookie

    Expert

    Jul 17, 2007
    22,182
    1,728
    You may not have given it a chance to cool down.
    Check to make sure the tip is screwed on properly, and that the handle cord is properly connected to the base.

    If you return it and it's working when they get it, you'll wind up being without it for a few weeks, and you'll pay for shipping both ways.
     
  10. Wendy

    Moderator

    Mar 24, 2008
    20,766
    2,536
    I have removed a hijack from this thread to here...

    Weller WES51 just died

    Given the threads age I am closing it.
     
Loading...
Thread Status:
Not open for further replies.