Vutrax CAD Issue

Discussion in 'Electronics Resources' started by Elec_Technic, May 11, 2010.

  1. Elec_Technic

    Thread Starter New Member

    May 11, 2010
    Here is my first post, can guarantee it wont be my last.:). Its about a small problem I have using the Vutrax CAD program.
    First of all, this is the first and only CAD program I have used, ever... so im quite a newbie when it comes to PCB CAD. Also, I began by reading the tutorial twice, then once I decided I didnt unterstand 99% of it, I googled beginners CAD guide. Now I feel I understand at least some aspect of PCB CAD.

    However, I am trying to create my own library for a particular project for work and I am having trouble in creating a library for it. I managed to actually create the library with a desired name, but whenever I try to save a newly created component, it just overwrites the one thats in the library.

    With me being as 'new' as I am, I would like to bet I am doing something wrong. Im guessing on other CAD programs there is a simple 'add component to library' button.

    Anyway, I appreciate any help from Vutrax or general CAD users. Thanks for the time to read :).

  2. beenthere

    Retired Moderator

    Apr 20, 2004
    Are you using reasonable file names?

    Say you're doing a series of radial capacitors, all with a .5 mm lead spacing. Saving individual ones a "Cap_.5" means the last one always overwrites the previous. Saving a "Cap_.5_7.5_dia" is different from the "Cap_.5_10.0_dia".

    Pick your own convention, but be consistent.
  3. retched

    AAC Fanatic!

    Dec 5, 2009
    Do you have a SAVE AS? If you are taking a diode out of the existing library and editing it to your specs, if you hit save, it is going to replace the existing diode.

    You have to use a 'save as' command to save it as a different part all together.
  4. Elec_Technic

    Thread Starter New Member

    May 11, 2010
    Hi again,
    To give a direct example of what im trying to do. I open vutrax, click on file then new (to create a new file). I then import a 24V supply from an existing library, I then change from schematic mode to library mode (because I couldnt find a way to import already made components while i was in library mode). I change the 24V supply to a 5V supply and click save as. It then asks we where I want to save it.
    If i click on my created library (for example 'project 1') it just overwrites the 24v supply I already had in there instead of adding it.
    I could just create shematics, rats nests, pcb etc by importing components from other libraries, just thought it would be more organised to list a pile of components we use for each job.
    Also, I can the components different names too :).
    Im wondering if it is because we are using version 13.2. It seems to be the free version that you can download.

    Thanx for the help so far :).

  5. Elec_Technic

    Thread Starter New Member

    May 11, 2010
    Problem Solved,
    As I suspected it was my lack of PCB CAD skills. The reason the library item was overwritten was because I thought each library item had to be created in a new seperate file. It turns out all I had to do was open a library file and create ALL components for that job. Not ONE and save them seperatly.

    In response to my 'new' and unfamiliar approach to PCB CAD, can anyone advise any introduction documentation or books I could read and learn? I have read a beginners guide that I searched for on a well known search engine but it was only 25 pages long. It did however explain a lot to me. For example what a silkscreen is used for.

    I am more than keen to learn more and maybe even come ''proffesional''.

    Thanks for all the help from Beenthere and Retched, much appriciated.