Vref on ICL7107

Discussion in 'The Projects Forum' started by farkhana, Jan 19, 2012.

  1. farkhana

    Thread Starter New Member

    Apr 14, 2011
    10
    0
    As stated in its datasheet:
    Count = Vin x 1000
    Vref

    But when I measure the Vref and Vin on ICL7107 and do the calculation, the Count doesnt show exactly on the 7segment display as in my calculation.
    Let say Vin = 0.076 and Vref = 1.293. So, Count = 58.
    but my 7segment display 78.

    Can anyone help me on this?
     
  2. praondevou

    AAC Fanatic!

    Jul 9, 2011
    2,936
    488
    What instruments did you use to measure the voltages ? Is it calibrated?

    What is your supply voltage ? Single or pos/neg?
     
  3. farkhana

    Thread Starter New Member

    Apr 14, 2011
    10
    0
    I'm using fluke multimeter (it's calibrated). And I use both pos/neg for ICL7107.
     
  4. praondevou

    AAC Fanatic!

    Jul 9, 2011
    2,936
    488
    Did you read page 6 "differential input/differential reference" of this datasheet?

    Some possible error causes are described here.

    Can you post a picture of how you wired it up and the corresponding schematic?
     
  5. bountyhunter

    Well-Known Member

    Sep 7, 2009
    2,498
    507
    My bench meter is built around the 7107. I added an external reference like the LM4041 and it eliminated a lot of the reading errors. The internal chip heating from the drivers makes the built in reference pretty inaccurate.
     
Loading...