Trouble with the pump voltage on my DIY PicKit 2 (Vpp Error) (double post)

Discussion in 'Embedded Systems and Microcontrollers' started by dan2zep, Aug 9, 2015.

Thread Status:
Not open for further replies.
  1. dan2zep

    Thread Starter New Member

    Aug 8, 2015
    4
    0
    My schematic is a lite version (doesn't include a voltage level detection nor is capable of programming a EEPROM).
    pickit2lite-blueroom-editted.jpg

    So far I had build it on a breadboard using the exact components and their respective values except for the schottky BAT41 and the 680 uH inductance which are nearly impossible to find in my country (Bolivia) and used the 1N5817 schottky and a 570uH inductance instead.

    The first time I test it I had this VPP error.
    error.jpg
    At least the PK2 Programmer does recognize it also I can download the firmware to the 18f2550. But I'm unable to use it to program anything.

    I double-triple-checked the circuit on two different breadboards (no kidding). Still no success. I've changed the 2N3906 for a more stable pnp BC547 and the 2N3906 for another npn BC557. Same error as before.

    I strongly believe the problem lies on one of four possibilities (hope it isn't all of them):

    a. The quality of the components (most are from chinese origin, nonetheless I checked them one by one with a tester).
    b. I double-triple-overlooked the same bloody error.
    c. (This one is interesting) On all the photos of working circuits I've noticed the inductance is placed very close to a transistor (perhaps the npn?) is this a special configuration for the Vpp Pump Voltage? Do I have to find exactly the 680uH? Is 110uH much of a difference?
    d. The transistors are causing the pump not to charge and maybe using MOSFETS will do.

    I hope I've given you some clear idea of my problem and thank you beforehand.
     
  2. dan2zep

    Thread Starter New Member

    Aug 8, 2015
    4
    0
    Sorry, I can't find the way to delete this thread. I had already moved it to the right place but it seems I'm not permitted to delete or even edit it.
     
  3. dan2zep

    Thread Starter New Member

    Aug 8, 2015
    4
    0
    And now the right one is deleted cause it was 'duplicated'. Great. Can any moderator please help me?
     
Loading...
Thread Status:
Not open for further replies.