Triac burst; capacitive supply

Discussion in 'General Electronics Chat' started by Vindhyachal Takniki, Sep 16, 2016.

Thread Status:
Not open for further replies.
  1. Vindhyachal Takniki

    Thread Starter Member

    Nov 3, 2014
    1. Attached is the circuit for capacitive supply making +5Vdc from 220Vac. Earlier I was using old zero cross ckt as marked in schemtaic , but now I have changed it to new zero cross ckt.

    2. Is this new zero cross circuit ok? Old zero cross ckt was reference I took from internet source.

    3. Problem is when I turned on this circuit suddenly triac burst.
    I have placed Q1 in the circuit as I have +5V powered micrcontroller whereas zener had 9.1V across it. So placed a bc547 which acts as gate.

    4. One issue I found that pin of R8 & microcontroller were not soldered i.e R8 was floating. Bt how does it can cause triac to burst? Or is there any other reason?
    Load is always 700ohm resistive one.
  2. ScottWang


    Aug 23, 2012
    The contents violated the UA(User Agreement), so this thread will be locked.
    • 6. Restricted topics. The following topics are regularly raised however are considered "off-topic" at all times and will result in Your thread being closed without question:
      • Any kind of over-unity devices and systems
      • Devices designed to electrocute or shock another person
      • LEDs to mains
      • Phone jammers
      • Rail guns and high-energy projectile devices
      • Transformer-less power supplies
      If You come across a thread or post discussing any of the above topics please report the thread so We can close, and if necessary remove, the offending thread/posts.
Thread Status:
Not open for further replies.