Treadmill Reebok I-Run Motor Controller Help needed

Discussion in 'The Projects Forum' started by MichiKrems, Jan 8, 2016.

  1. MichiKrems

    Thread Starter New Member

    Jan 8, 2016
    9
    1
    Hello from Austria

    First sorry about my English ;-)
    treadmill Controll Board JD-230E/E
    My tredmill stoppes working after differend Intervalls (sometimes 8min,sometimes 15min ,..)Power off wait a Night and same thing happens.
    Now i disassembly the treadmill an when i touch the controlleboard (rem Marked component in attached pics)
    it starts working.
    Solderd it out to dissasemble butt no way to identify this thing.
    Can anyone Help?
     
  2. Dodgydave

    Distinguished Member

    Jun 22, 2012
    4,972
    744
    Its a pwm regulator thats potted, to prevent tampering, but what voltage is it supposed to be giving out?
     
    Last edited: Jan 8, 2016
  3. MichiKrems

    Thread Starter New Member

    Jan 8, 2016
    9
    1
    I dont know
    Found No Schematic about this controller
     
  4. Dodgydave

    Distinguished Member

    Jun 22, 2012
    4,972
    744
    Are there any voltage markings on the pcb, and can you show pictures of the track side?

    Have you resoldered it to cure any broken joints?
     
    Last edited: Jan 8, 2016
  5. MaxHeadRoom

    Expert

    Jul 18, 2013
    10,511
    2,369
    Obtain so freezer in an aerosol can (Arctic Air) this is to enable detection of components that fail when getting hot.
    You may pin down which component this way.
    Max.
     
  6. MichiKrems

    Thread Starter New Member

    Jan 8, 2016
    9
    1
    Re Solderd but now no funktion to the motor.
     
  7. Dodgydave

    Distinguished Member

    Jun 22, 2012
    4,972
    744
    Unless there is a broken track, the module must be damaged, looks like is a pwm speed contoller,.
     
  8. MichiKrems

    Thread Starter New Member

    Jan 8, 2016
    9
    1
    Found this in Web
    Maybe helpfull?
    Dont want buy a new Board ;-( its expensive

    All measurements of voltages are ok as far as I understand it


    But on the gate at the mosfet I always get just only 0V
     
  9. MaxHeadRoom

    Expert

    Jul 18, 2013
    10,511
    2,369
    I would be tempted to reverse engineer it up to the module, this may then give a clue as to what is in it and design a replacement.
    Max.
     
  10. Dodgydave

    Distinguished Member

    Jun 22, 2012
    4,972
    744
    Looks like its switching the mosfet on to control the motor, there is a current sense pin on it from the Source on the fet, the two presets are for speed and current (amp)limit, two 12v supply pins, and one pin has a 100 ohms resistor going to a connector, whats this for needs measuring!!?

    My guess is a pwm circuit and depending what the Unknown input pin does..probably to turn it on/ off.

    If it is a pwm controller, you can make one from a 555 timer.
     
  11. MichiKrems

    Thread Starter New Member

    Jan 8, 2016
    9
    1
    Thanks Dodgydave
    Can you help me to identify the pins ?
    1 = driving the Mosfet
    2= ?
    3= Speed Limiter /Controll
    4= Amp Limiter
    5=0-5 V this is the signal from Diplay Computer( Speed switches 0,8-14 km/h)
    6= GND
    7= 12V
    Witch 555 Timer would be right.Can you tell where Find a right schematic ?
     
  12. Dodgydave

    Distinguished Member

    Jun 22, 2012
    4,972
    744
    Last edited: Jan 12, 2016
  13. MichiKrems

    Thread Starter New Member

    Jan 8, 2016
    9
    1
    thanks
    hmm realy pin 2 ?not pin 1
     
  14. Dodgydave

    Distinguished Member

    Jun 22, 2012
    4,972
    744
    Sorry pin 1 my mistake,,, doh!
     
  15. MichiKrems

    Thread Starter New Member

    Jan 8, 2016
    9
    1
    is this what you mean ?

    Pins 2,3,4,5 not in use
    Speed controlled per poti over 555 Timer ?
    If the i want to use the "Speed switch" at the treadmill Display can I connect pin 5 from paneel to pin 6and 2 from 555 timer ?
     
  16. Dodgydave

    Distinguished Member

    Jun 22, 2012
    4,972
    744
    No, the 555 will need to be controlled with its own preset resistor, otherwise the 555 can be voltage controlled on pin 5, but not with 0-5v but 6-10v,.

    I would start by making or buying the pwm pcb, and trying it on the mosfet, to see if it works, then start modifying the voltage control using an op amp.

    Or you may use an op amp pwm controller like this...
    http://circuitswiring.com/circuit-diagrams/24/uploads/allimg/100710/213ZLO3-1.gif
     
  17. MichiKrems

    Thread Starter New Member

    Jan 8, 2016
    9
    1
    Ok
    Later i will test the mosfet + on gate should turn motor on at full speed i think.
    if this is working i gona buy the attached controller and try to integrate.
    then i will report the summary ;-)
    Thanks for time and help
     
    Charleyedward likes this.
  18. Charleyedward

    New Member

    Aug 18, 2016
    2
    0
    Hello MichiKrems,
    Did you manage to fix the board? I am having the same problem you had for the last 2 days. My control board model is exactly the same as yours. Power to motor from Mosfet stops working after a minute roughly. Any advise will be really helpful.
    Thanks,
    Charley
     
  19. Charleyedward

    New Member

    Aug 18, 2016
    2
    0
    Pic of my conrol board...
     
  20. MichiKrems

    Thread Starter New Member

    Jan 8, 2016
    9
    1
    Hello
    In my case i changed THe Original Controller .speed is now controlled via extern poti which i Mountet nett the display
     
Loading...