Transmitting Data through 74241 Tristate Buffer

Discussion in 'The Projects Forum' started by robby991, Jan 12, 2009.

  1. robby991

    Thread Starter Active Member

    Dec 17, 2007
    79
    0
    Hi everyone. I am looking to transmit data though a 74241 tristate buffer and I am having problems. When the tristate buffer is activated, the pulses from a function generator pass through fine, but pulses from my programmed PDA will not go through. The PDA pulses have an amplitude of 3V. Any reason why these won't pass?
     
  2. beenthere

    Retired Moderator

    Apr 20, 2004
    15,815
    282
    You have two enable lines. If you are trying pass alternate sets of 4 bits, you need to activate the correct enable line.
     
  3. robby991

    Thread Starter Active Member

    Dec 17, 2007
    79
    0
    The enable line is the same for both. My PDA was not working so I removed it and added the function generator in the same pin to see if that worked, and it did. Something about my PDA pulses won't pass through.
     
  4. eblc1388

    Senior Member

    Nov 28, 2008
    1,542
    102
    Hi robby991,

    Is this the same project as one of your previous thread on enabling the tri-state buffer with 555 and 7447 and you are having trouble with power ON reset?

    Is the reset problem now OK after the modification? If so, you'll need to close that old thread by saying so.
     
  5. robby991

    Thread Starter Active Member

    Dec 17, 2007
    79
    0
    Yes the power on works fine. I am sorry, I thought I replied to that. Thank you by the way.
     
  6. eblc1388

    Senior Member

    Nov 28, 2008
    1,542
    102
    You had not. I just checked.

    A thread remains open if the original owner of the thread (that's you) does not follow it up with a statement saying the current problem has been solved.

    You should do that or else sometimes later some other people will post and ask what happened?
     
  7. robby991

    Thread Starter Active Member

    Dec 17, 2007
    79
    0
    All set. Sorry :)
     
  8. robby991

    Thread Starter Active Member

    Dec 17, 2007
    79
    0
    I still can't figure out this problem with transmitting the data through the tri state buffer with my PDA. Does anyone have any suggestions? The generator works fine.
     
  9. robby991

    Thread Starter Active Member

    Dec 17, 2007
    79
    0
    Thanks Alberto. I will check that. If this is the case will a schmitt trigger aid in pulse shaping to solve this problem?
     
Loading...