Transformer woes!

Discussion in 'General Electronics Chat' started by Dragon, Sep 27, 2007.

  1. Dragon

    Thread Starter Active Member

    Sep 25, 2007
    42
    0
    I am trying to use transformers in linear switching, using 2 FET's at the primary side of a ceter tapped transformer. The secondary windings are attached to a multiplier so that I can get around 700V.

    The problem is that the transformers either saturate much earlier, or if the dont, they never provide the required current drive at the output, which limits the output power.

    I have tried using PICO 32688 and PICO 32694, both of which have rated output powers at 3W.
    The maximum Im getting is under 1W. Any suggestions on increasing the current drive?
     
  2. thingmaker3

    Retired Moderator

    May 16, 2005
    5,072
    6
    Is your input frequency between 30KHz and 60KHz?

    What is the voltage to your FETs, and which FETs are you using?
     
  3. Dragon

    Thread Starter Active Member

    Sep 25, 2007
    42
    0
    Thanks for your reponse.

    Yes the frequency is between 30K to 50K.
    Im using IRLL014N (HEXFET power mosfet). The drain voltage to each of them is upto 12V (controlable).
     
  4. thingmaker3

    Retired Moderator

    May 16, 2005
    5,072
    6
    So far so good... how are you driving your MOSFETs? You're using at least 6 or 7 volts to turn on the gates, yes? And you've got good topology for turn-off? And a nice, symmetrical drive signal?
     
  5. Dragon

    Thread Starter Active Member

    Sep 25, 2007
    42
    0
    Yes, about 6, 7 volts to turn on the gates. The turn off is perfect.
    I am required to make a feedback from the output of the multiplier to the primary windings at the center-tap via an opamp (which has 12V variable supply through a potentiometer at its non-inverting end).

    The idea is to control the output(at the multiplier end) using this variable supply connected to the opamp. And at this point,the problem starts.

    Due to insufficient current drive at the secondary, the opamp refuses to be stable or in other words, gives almost no control at its output. Hence the voltage to the primary stays almost stable.
     
  6. thingmaker3

    Retired Moderator

    May 16, 2005
    5,072
    6
    Is the variable supply an SMPS? If so, is the output well filtered?

    I think what I would try is checking o/p from the xfmr with the feedback disconnected. If that works, I'd start looking at the feedback. If it doesn't work, then the inverter would come under scrutiny.
     
Loading...