Traffic light circuit

Discussion in 'The Projects Forum' started by sea_ha, Dec 22, 2010.

  1. sea_ha

    Thread Starter New Member

    Dec 22, 2010
    3
    0
    hi
    The project that i have to do is a two ways traffic light. i am supposed to simulate it using proteus . The simulation is running in the correct order but the timing is not right . there should be a 25s (for the green and red lights ) and a 4s (orange light) , while my simulation is running in a sequence of 10 seconds between each light .
    i have everything u need to know about my project attached.
    am sorry i attached many pics but i wanted to provide all the details
     
    • 1.jpg
      1.jpg
      File size:
      197.4 KB
      Views:
      69
    • 2.jpg
      2.jpg
      File size:
      155 KB
      Views:
      53
    • 3.jpg
      3.jpg
      File size:
      99.7 KB
      Views:
      64
    • 4.jpg
      4.jpg
      File size:
      281.7 KB
      Views:
      51
    • 5.jpg
      5.jpg
      File size:
      264.3 KB
      Views:
      68
    • 6.jpg
      6.jpg
      File size:
      265.8 KB
      Views:
      58
  2. sea_ha

    Thread Starter New Member

    Dec 22, 2010
    3
    0
    i think my problem is with the two 74121 ...they don't seem like they're doing their job but i don't know how to solve it
     
    Last edited: Dec 22, 2010
  3. sea_ha

    Thread Starter New Member

    Dec 22, 2010
    3
    0
    come on guys...i haven't had a single reply yet :(
     
  4. thatoneguy

    AAC Fanatic!

    Feb 19, 2009
    6,357
    718
    It appears you have an oscillator for each state.

    Have you looked at the circuits using a 4017 decade counter with a steady clock for all output states as a base idea?

    Search forum for "traffic light" for quite a few ideas.

    Your attachements are hard to piece together, easier to do a full print-screen, save as .PNG, and the browser will allow scrolling/resizing.
     
Loading...