temperature sensor noise

Discussion in 'The Projects Forum' started by mah, Jan 25, 2014.

  1. mah

    Thread Starter Active Member

    Mar 15, 2010
    276
    2
    I use Lm35 to measure PV panel surface temperature with a cable its long is almost 1 meter but i displayed the output on oscilloscope and there is spikes added to the dc output how to cancel these spikes( i don't have any specified frequency )
     
  2. bertus

    Administrator

    Apr 5, 2008
    15,645
    2,344
    Hello,

    Did you see the schematics in the datasheet for remote sensing?
    The figures 5 and 6 in the datasheet might give you a hint.

    Bertus
     
    • lm35.pdf
      File size:
      303.7 KB
      Views:
      36
  3. donpetru

    Active Member

    Nov 14, 2008
    186
    25
    Can you show us the circuit to see how you interfaced LM35.
    LM35 may be interfered by the circuit to which it is connected.
    Show me that circuit? Is that an ADC?
     
  4. mah

    Thread Starter Active Member

    Mar 15, 2010
    276
    2
    there is no circuit it is just the output of LM35 connected to oscilloscope .
     
  5. crutschow

    Expert

    Mar 14, 2008
    12,988
    3,226
    A resistor in series with the output and a capacitor to ground at the end of the wire to form a low-pass filter should help. Try 1kΩ and 1μF to start.
     
  6. donpetru

    Active Member

    Nov 14, 2008
    186
    25
    Then try connecting module LM35 as shown below.
     
  7. THE_RB

    AAC Fanatic!

    Feb 11, 2008
    5,435
    1,305
    Since the solar panel temperature is unlikely to change faster than a couple of 'C per second, that's a max voltage slope of 20mV/sec on the LM335 output pin. You could probably use a 100uF or 1000uF cap with no issues. :)
     
Loading...