Tcs230 color measurement problem

Discussion in 'The Projects Forum' started by thavamaran, May 11, 2009.

  1. thavamaran

    Thread Starter Active Member

    Feb 21, 2008
    67
    0
    Hi guys, im currently undergoing some measurement with TCS230 light to frequency converter, its actually a cmos color sensor, so the measurement result was made in period measurement.

    For white the output was not almost the same, but actually according to bitmap resolution, the R,G,B value for white is 255,255,255, but through this sensor, the output frequency is not really that similar, it actually varies. and for black its suppose to be R,G,B=0,0,0 and the output of the sensor is not really similar.

    same when i place the sensor on Red which is R,G,B=255,0,0 and there is no green or blue intensity on this particular color, but still im getting output reading. so i need suggestion that what would be the problem? i feel its related to physics.
    here is the link for datasheet of the sensor im using. thank you.

    http://www.w-r-e.de/robotik/data/opt/tcs230.pdf
     
  2. bertus

    Administrator

    Apr 5, 2008
    15,649
    2,348
    Hello,

    The characteristics for the colors are overlapping.

    [​IMG]

    Are you using the filter described in the graph?

    Greetings,
    Bertus
     
  3. StayatHomeElectronics

    Well-Known Member

    Sep 25, 2008
    864
    40
    How are you generating the different colors?

    How are you limiting background light from being detected?
     
Loading...