Stepper Motor problems

Discussion in 'General Electronics Chat' started by Neil Houston, Feb 13, 2015.

  1. Neil Houston

    Thread Starter New Member

    Feb 12, 2015
    2
    0
    Hi I am currently struggling to get my stepper motor working using the L293D with the Genie E28. I need to allow the stepper motor to go move in a clockwise motion but when a switch (D3) is pressed turn anti-clockwise.
    The motor is activated using different switches to allow different speeds, D0, D1 and D2 are used for this, slow, medium and fast speeds. There is also a variable resistor (A0) which is used as an alternative to the digital inputs although with the same principle, where the speeds are indicated by the analogue signal, 30-100 -Slow, 101-170, Average and 171-255 - fast.
    The LCD and LEDs just displays what speed setting it's on.
    Have I connected the L293D in the correct configuration? As nothing happens when the activation buttons are pressed.

    I have attached the circuit for reference
    Thanks for your time circuit.png
     
  2. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,801
    1,105
    Confirm you have 5V at all points requiring it.
     
  3. ScottWang

    Moderator

    Aug 23, 2012
    4,855
    767
    1. Using the R range of multi-meter to measure all the wiring, to make sure all the wires is ok.
    2. If you don't have any experience about how to control the stepper motor then you can see the Stepper Motor Forward And Reverse Testing circuit.
     
Loading...