Simulator that can actually simulate this?

Discussion in 'General Electronics Chat' started by Zortz, May 2, 2014.

  1. Zortz

    Thread Starter New Member

    May 2, 2014
    16
    0
    Hey!
    I am starting with electronics and was using Multisim for simulations. I am following Make - Electronics book.

    Multisim is quite nice but now i found a circuit that will not work there.

    The problematic circuit:
    [​IMG]

    Knowing that people like different simulators i would like to ask you for a favor:
    Could you draw this same example in your favourite simulator and report back here what happens.


    From the results i would like to find simulator that works with these simple circuits.


    Thank you very much!
     
  2. t06afre

    AAC Fanatic!

    May 11, 2009
    5,939
    1,222
    Why does this circuit not work you in your simulator? By the way what is your source for this circuit. The circuit do not look coorect as shown. The resistor vaules will ensure that the LED is off no matter with 6 volt DC as supply voltage
     
    Last edited: May 2, 2014
  3. Zortz

    Thread Starter New Member

    May 2, 2014
    16
    0
    Multisim goes crazy, sometimes giving errors other times just stopping the capacitator charging.

    There is a thread in multisim support forums about this and some guys modified it alot to get it working. But i would like it without modifications because it is working in real life why not in simulator?


    Edit: this circuit is direct screenshot from "Make-electronics"
     
  4. inwo

    Well-Known Member

    Nov 7, 2013
    2,433
    315
    Does simulation allow input for "put"?
     
  5. bertus

    Administrator

    Apr 5, 2008
    15,648
    2,346
  6. Zortz

    Thread Starter New Member

    May 2, 2014
    16
    0
    I made picture of multisim. This is how it gets stuck and nothing happens anymore:
    [​IMG]
     
  7. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,800
    1,103
    Just about works as is in LTspice, depending on choice of LED model. Works better, and less dependent on LED type, if 15k is replaced by higher value, e.g. 22k.
     
  8. RichardO

    Well-Known Member

    May 4, 2013
    1,235
    384
    Just curious... Where did you get your PUT model?
     
  9. Zortz

    Thread Starter New Member

    May 2, 2014
    16
    0
    Thank you for the results!
    I tested 22k in multisim and it is working also. Quite small drift from the real circuit so i think it is acceptable.

    However still wondering why it is not working as is and how can LED type make any difference here?

    Thanks!
     
  10. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,800
    1,103
    Free download from Yahoo LTspice User Group.
     
    RichardO likes this.
  11. Alec_t

    AAC Fanatic!

    Sep 17, 2013
    5,800
    1,103
    Transistor gain? Junction forward voltage drop? Leakage current? ....?
     
Loading...