Setting "Origin" in Eagle?

Discussion in 'General Electronics Chat' started by spinnaker, Jan 24, 2016.

  1. spinnaker

    Thread Starter AAC Fanatic!

    Oct 29, 2009
    4,887
    1,016
    I find Eagle so overly complicated. Not intuitive at all. Unfortunately one of the really decent applications that produces gcode isolation layers is PCB Gcode and only works as a ULP in Eagle.

    Fortunately, I have found I can create my PCBs with Diptrace, export to PCAD format and import into Eagle. Produce the gcode with the PCBGcode ulp.

    My problem is that my drawing in LinuxCNC does not start where I expect and I think it is has do do with where the origin is defined. Or at least that is what Diptrace calls it. In Diptrace it is a horizontal and vertical line. If I place my drawing in the upper left and convert to gcode with FlatCam everything goes as expected. The problem is FlatCam is kind of clunky so I might rather use PCBGcode.

    I noticed that Eagle has a little + sign on new drawings. But that appears to represent the lower right hand corner of the board?


    I tried placing the drawing in the lower right corner of the board but the drwaing is still about an inch to the left where it should be. The Y axis is also off.

    I am assuming this is an origin issue in Eagle but I might be wrong. Is there a way to set the origin in Eagle? If so how is it done?
     
  2. jpanhalt

    AAC Fanatic!

    Jan 18, 2008
    5,699
    907
    Are you asking about aligning an arbitrary "0" for an entire board or something like a board/group to the Eagle zero or are you concerned about aligning a single part to the Eagle zero?

    John
     
  3. mcgyvr

    AAC Fanatic!

    Oct 15, 2009
    4,771
    971
    One would expect the 0,0 point in diptrace to be the 0,0 point in linuxcnc... is that not whats happening? if so how is it off..specifically?
     
  4. spinnaker

    Thread Starter AAC Fanatic!

    Oct 29, 2009
    4,887
    1,016

    No not when I export the gCode with PCBGcode. I placed the drawing in the lower left which I assume is the board but after I export my gCode and load the file into linux cnc, I can't get the tool above the lower left without adjusting the touch off position. I am attaching the gCode.

    The test.ngc file is the one that was produced with FlatCam and seems to work fine in LinuxCNC.

    The test.pcb.bot.etch.tap file was produced by pcbgcode in Eagle.


    And it isn't DipTrace where I have the issue. In Diptrace, ff I have my drawing in the upper left, of the origin, export to gerber, import to flatcam and convert it works fine in linuxcnc.

    Exporting from pcbgcode in Eagle is where the issue lies.
     
  5. spinnaker

    Thread Starter AAC Fanatic!

    Oct 29, 2009
    4,887
    1,016
    Strange. I also generated the gcode for the top side of the board and everything lines up perfectly on the Xaxis.
     
  6. SLK001

    Well-Known Member

    Nov 29, 2011
    821
    229
    For boards and schematics, the origin is always at (0,0). For parts, I usually set it to the geometric center of the part (this in part origin, not drawing).

    To "set" the origin on your drawing different than (0,0), you have to move the entire drawing (in reality, the origin will still be at (0,0), but you can move where it appears on your drawing). If you want the origin to be in the middle of the page, turn on ALL layers and select ALL, then MOVE everything until you have (0,0) in the middle of the page. If you want the origin to be 1" to the left and 1" down from your drawing, move ALL the layers up 1" and right 1".
     
  7. spinnaker

    Thread Starter AAC Fanatic!

    Oct 29, 2009
    4,887
    1,016
    But how do you set the origin in Eagle?


    I don't think it is an origin issue anyway. If I use the option in pcbgcode to mirror the bottom then everything lines up perfectly. But of course everything is then mirrored in linuxcnc so will mill mirrored.

    This is what my board looks like in Eagle. I assume this is normal because you are looking from the top down?

    upload_2016-1-24_20-53-26.png
     
  8. spinnaker

    Thread Starter AAC Fanatic!

    Oct 29, 2009
    4,887
    1,016
    Well finally got an answer from the PCBGode Yahoo group. Normally you set you X zero in the lower left. Turns out here it is lower right. THat simple.
     
Loading...