Sensor calibration problem

Discussion in 'The Projects Forum' started by prescott2006, Nov 3, 2010.

  1. prescott2006

    Thread Starter Active Member

    Nov 8, 2008
    72
    1
    Can MCP6001 be replaced by LMP2231? I am calibrating Flexiforce, but I am using LMP2231, and the pressure that can sensed seem not sensitive, i.e. no voltage changes when small load is applied. I am wondering whether is the opamp not suitable or not. FYI, the feedback resistor has been tuned to largest that is 100k, even I tried 1M but still no response on small load. Attached is the Flexiforce recommended drive circuit.
     
  2. hgmjr

    Moderator

    Jan 28, 2005
    9,030
    214
    Are you using a +5 and -5 volt power supply as called for in the circuit?

    hgmjr
     
  3. prescott2006

    Thread Starter Active Member

    Nov 8, 2008
    72
    1
    Yes, I am using the +5 and -5 as in the circuit.
     
  4. hgmjr

    Moderator

    Jan 28, 2005
    9,030
    214
    If you have confirmed that your connections are correct and it still does not work, then it may be that your opamp has been damaged. Do you have a second part that you can try?

    hgmjr
     
  5. prescott2006

    Thread Starter Active Member

    Nov 8, 2008
    72
    1
    So do you mean that the LMP2231 can be a perfect substitution?
     
  6. hgmjr

    Moderator

    Jan 28, 2005
    9,030
    214
    The word perfect may be an over statement but certainly it is useable. Your application is not that demanding in either current or frequency so it a likely candidate.

    hgmjr
     
Loading...